LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

How to use a thermal camera in Labview (Optris PI 640)

Solved!
Go to solution

Hello, I am working on a project which involves the use of a thermal camera (Optris PI 640), but I can not get labview to view images/video from the camera. I tried using vision acquisition. It recognizes the camera, but all it shows is a static green screen. I tried the example VI's that we were given (attached below) but for some reason all they do is try to print something, which baffles my team. Two options that I thought up are as follows

 

1) Use labview to open up the software that the camera came with and extract the image from there (which is what essentially the example VI does).

 

2) Get labview to get the camera working with vision acquisition like any other USB camera.

 

Which option would be more feasible? Thank you. I know I left out a lot of information, I will gladly provide any details.

0 Kudos
Message 1 of 26
(2,265 Views)

I don't have experience with this specific type of camera but here are a couple of suggestions.

Are you able to make the camera work with the manufacturer's software on the same computer than the one you want to use LabVIEW with?

Does you camera need triggering to acquire images?

If you try to use IMAQ (vision toolkit) to acquire the images, you might not have access to some functions of the camera but if you can start triggering in someway, it should work.

If the manufacturer provides a LabVIEW driver, that is probably your best bet. Let us know exactly what you try (which VI among those) and what was the exact problem if you still cannot make it work.

Marc Dubois
HaroTek LLC
www.harotek.com

new_CLA_100x100.pngnew_CTD_100x100.pngnew_instructor_100x100.pngNI_Alliance_Partner_Logo_243x76.jpg

0 Kudos
Message 2 of 26
(2,255 Views)

Yes, on the same computer,  it will work with the default program but won't with labview. 

I'm not sure what you mean by triggering, but the camera can do a video stream with the default program without the need to press a button or anything to start streaming. 

I attempted to use imaq, but I have no idea how to use it to make the camera an input and out put an image from it.

The only thing driver-wise that it told me to download was the latest version of labview realtime. I'm not sure exactly what that is used for sir

0 Kudos
Message 3 of 26
(2,230 Views)

As for what I have tried...I tried to run all of the example vi's. But every time on the error out indicator, it displays "error" and writes out the file path for the exe for the default program. I'm not sure what's going wrong here

0 Kudos
Message 4 of 26
(2,229 Views)

I don't know if you had searched the forum for some answers but here is a thread that might help you: forums.ni.com/t5/forums/v3_1/forumtopicpage/board-id/7111/thread-id/1732/page/1

Marc Dubois
HaroTek LLC
www.harotek.com

new_CLA_100x100.pngnew_CTD_100x100.pngnew_instructor_100x100.pngNI_Alliance_Partner_Logo_243x76.jpg

0 Kudos
Message 5 of 26
(2,221 Views)

I appreciate it, but I saw that post a while ago and it might as well be in hieroglyphs. I did do some research about call back features in labview (in regards to option 1 of my first post) and it said that I would need a c based wrapper, but I am not familiar with it at all so I was hoping I would get some help with it on here.

0 Kudos
Message 6 of 26
(2,216 Views)

Hi gookman,

 

Based on the electrical specifications in the manual provided by PI, it looks like you are using a USB 2.0 camera.

 

We have a troubleshooting guide to help troubleshoot USB 2.0 cameras: Troubleshooting USB 2.0 (DirectShow) Camera Installation Problems.  This is where I would start.

 

The fact that the camera manufacturer (I'm assuming) provided an API is a good sign - it means we should expect LabVIEW to be able to work with the SDK - I also suspect that you may want to reach out to Optris to see if they have any suggestions.

 

Regards,

 

George B.

Applications Engineer

National Instruments

0 Kudos
Message 7 of 26
(2,200 Views)

I appreciate your reply, I will definitely try it out

0 Kudos
Message 8 of 26
(2,197 Views)

Hello,

I'm also interested in how to use this camera under Labview.
Have you found a solution?

Thank you in advance.

0 Kudos
Message 9 of 26
(2,123 Views)

I sure did. Here are the steps off top of my head

1. Make a folder in the pi connect directory called "imager.exe" (I know it's weird) on the same level as the actual imager.exe. You're gonna have to do some moving stuff around. 

2. Move every file that's not a folder into the newly created "imager.exe" folder. Including imager.exe. 

3. Run one of the getting stated vi's.

 

There are some extra steps but I'm not sure if you need to do them. I can post them and screenshots if you need them

0 Kudos
Message 10 of 26
(2,120 Views)