LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to set LabVIEW to not start with an empty VI - with keyword in the INI?

Solved!
Go to solution

Good day!

I wonder that this seems to be unquestioned. LV always comes up with an empty VI unless I start it by double-clicking on a specific VI.

Can this be changed? It's a bit annoying to always close the two empty VI windows. In the Options there is nothing, as far as I see it.

 

My thinking is that a keyword in the INI could do that, but which one. I searched if there is sort of a reference for the INI keywords, but to no avail.

0 Kudos
Message 1 of 7
(872 Views)

Hi MaSta,

 


@MaSta wrote:

LV always comes up with an empty VI …

It's a bit annoying to always close the two empty VI windows.


You only need to close the frontpanel, then the block diagram is also closed… 😄

 


@MaSta wrote:

My thinking is that a keyword in the INI could do that, but which one. I searched if there is sort of a reference for the INI keywords, but to no avail.


Simple test:

  1. quit LabVIEW if open
  2. create a backup of your LabVIEW.ini
  3. delete the LabVIEW.ini
  4. start LabVIEW

What happens?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 2 of 7
(867 Views)

Yes, yes, but closing the FP is already too much. 😁

INI: Nice, but only works once. 

0 Kudos
Message 3 of 7
(858 Views)

Hi MaSta,

 


@MaSta wrote:

INI: Nice, but only works once. 


So you deleted the LabVIEW.ini and upon starting LabVIEW you get the usual GettingStartedWindow (GSW)?

And after quitting and starting LabVIEW the next time the GSW does not show, but you get an empty VI again?

 

What is the content of the LabVIEW.ini after the first run?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 4 of 7
(847 Views)
Solution
Accepted by topic author MaSta

Found it! Now it works.

I think this is due to a bad translation to German. There is an option "Startfenster überspringen". I didn't connect the main window of LV as the Startfenster. A starting window or screen is usually the splash screen you see when LV starts and which, as I realize now, LV would still show.

Doh!

0 Kudos
Message 5 of 7
(835 Views)

Hi MaSta,

 


@MaSta wrote:

I think this is due to a bad translation to German. There is an option "Startfenster überspringen". I didn't connect the main window of LV as the Startfenster.


So "Getting Started Window" is translated to "Startfenster": not that bad I guess… 🙂

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 6 of 7
(826 Views)

Getting Started isn't better. Let's say it's an "overall bad term". For me it's a main window, much clearer. The term "Getting started" is not to be found anywhere in that window.

0 Kudos
Message 7 of 7
(820 Views)