LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to remove Run-Time 8.5.0?

Solved!
Go to solution
Highlighted

I getting "Cannot install" "higher version already installed" error when I attempt to install an .exe. I see in Max that I have RunTime 8.5.0 installed and I'm using LV 8.2.1. How do I remove Run-Time 8.5.0?

 

Thanks.

0 Kudos
Message 1 of 5
(1,258 Views)
Go to Add/Remove programs in Windows control panel and pick National Instruments.  That should let you select which NI software components to uninstall.
0 Kudos
Message 2 of 5
(1,241 Views)
Solution
Accepted by topic author zilla

LabVIEW runtime engine versions do not appear in "Add or Remove Programs" after LabVIEW 8.0 versions.  In 7.x versions there where provisions to remove runtime engine by this method.  Inorder to the runtime engine, navigate to this path: C:\Program Files\National Instruments\Shared\ProductCache Here you will find the uninstallers for all the software installed with LabVIEW.  Use this uninstaller to uninstall the required components.

With regards,
JK
(Certified LabVIEW Developer)
Give Kudos for Good Answers, and Mark it a solution if your problem is solved.
0 Kudos
Message 3 of 5
(1,235 Views)

JK1 wrote:

LabVIEW runtime engine versions do not appear in "Add or Remove Programs" after LabVIEW 8.0 versions.  In 7.x versions there where provisions to remove runtime engine by this method.  Inorder to the runtime engine, navigate to this path: C:\Program Files\National Instruments\Shared\ProductCache Here you will find the uninstallers for all the software installed with LabVIEW.  Use this uninstaller to uninstall the required components.


I believe your answer depends on what kind of LabVIEW you have installed on your machine.  I looked at my LabVIEW installation which is the LabVIEW Prof. Development Suite, and yes, there is no Runtime Engine that can be uninstalled for LV 8.2, 8.5, 8.6 (the versions I have installed on this machine.)  I looked at a machine that is not a development PC but just runs LV 8.6 executables I created.  It does have the runtime engine listed under the NI software.  I believe that is because if you have a full development environment, you don't have have a runtime to uninstall.  The runtime engine is a part of the full LabVIEW installation.

Message Edited by Ravens Fan on 03-26-2009 09:24 AM
Message 4 of 5
(1,225 Views)

That worked!

 

Thanks!

 

Cheers...

0 Kudos
Message 5 of 5
(1,186 Views)