LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to print on Dymo LabelWriter with Labview

Solved!
Go to solution

Hello

 

We have a production computer with Windows 10 and a program that I once developed. Now it was time to upgrade this computer to a new Windows 11 computer and the Dymo printer does not work anymore. 

 

See attached vi. 

 

On my new computer I have downloaded alot of versions and registered all kind of files but it just gives me the errors. 

Noticed that the ActiveX was renamed to Dymo.IDymoAddin6 while the old name was Dymo.IDymoAddin3.

Selected from "DLS SDK COM Type Library Version 1.0"

 

Do you have any clue what I'm doing wrong?

0 Kudos
Message 1 of 13
(436 Views)

Can someone help me with this? 

 

Or do we have to buy another brand? Any recommendations? Must be stickers.

0 Kudos
Message 2 of 13
(348 Views)

We use the DYMO Label v8 SDK for 4xx and 5xx series label printers under Windows 10 and 11.

To actually be able to print the DYMO Label Software v8.7.x also needs to be installed and connected to a printer first !

 

The constructors you will need are Interop.Dymo(1.0.0.0).DymoLabelClass and .DymoAddinClass (Interop.Dymo.dll).

 

snip.png

Message 3 of 13
(341 Views)

Yeah i remembered that i used v7.x of the Dymo software.

 

But where do you find Interop.Dymo.dll that you used? 

0 Kudos
Message 4 of 13
(323 Views)

I believe the installer creates a subfolder in the Documents folder for the current user and there are several copies in there.

 

You can look in: %USERPROFILE%\Documents\DYMO Label v.8 SDK\DLS SDK\Samples\High Level COM\dotNET Samples\C# Sample\bin\Release

Message 5 of 13
(315 Views)

Yes i found it. 

 

But this is a .NET application and not ActiveX. But how do I build a .NET application in labview?

0 Kudos
Message 6 of 13
(305 Views)
  • CTRL+Space to open quick drop menu, search for Constuctor Node.
  • When you place the node a selection menu will open.
  • Click browse and navigate to the Interop.Dymo.dll (keep a copy in the same folder when building an exe)
  • Select the objects mentioned above

Creating properties and methods is the same as for ActiveX objects.

 

RamonG_0-1718970011618.png

RamonG_1-1718970223404.png

 

 

Message 7 of 13
(298 Views)

I understand. But i get:

1172 Constructor Node Error

Class not registered 

 

slarve_0-1718974214010.png

I even tried to regsvr32 it, but it says it can't be registered. 

0 Kudos
Message 8 of 13
(288 Views)

Unfortunately this is where my knowledge of .NET assemblies ends.

 

Out of curiosity have you installed the Dymo Label software v8.7.4 and connected a printer? It seems to be a dependency for using the SDK.

0 Kudos
Message 9 of 13
(274 Views)

I have a printer connected to the production computer. (Have labview trial on that computer)

I still get an error when I try to use print() but not when I use GetType(). 

 

Got this error message: (translated from Norwegian with google translate)

Invoke Node System.Reflection.TargetInvocationException: The target threw an exception during invocation.
	Inner Exception: System.InvalidCastException: Unable to cast COM object of type 'Dymo.DymoAddInClass' to interface type 'Dymo.IDymoAddin6'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{0C7AADEF-16FC-400D-A827-3F7A93A94DF7}' failed due to the following error: There is no support for this interface (Exception from HRESULT: 0x80004002 ( E_NOINTERFACE)). <append><b>System.InvalidCastException</b> in dymo_test_net.vi

 

Will look into that Dymo Label software. The SDK you mean?

I have SDK installed, old Dymo Label version 7.7 and new Dymo Connect v1.4.6

0 Kudos
Message 10 of 13
(244 Views)