LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to get PXI 5152 working in LabVIEW 7.0

Hi,..I recently purchased a PXI 5152 digitiser. The driver CD had NI Scope 3.4 which, when installed worked fine. But it also installed NI DAQ MX 8.5 (min. requirement) and removed my older version of DAQMx.. This new version DAQMx 8.5 does not support LV7.0. (My APE is LabVIEW 7.0.) So I can't get any DAQMx I/0 blocks from LabVIEW.
 
 
When I uninstalled DAQMx 8.5, NI Scope 3.4 also got removed. Then I rolled back to my old config of DAQ and Scope 2.5. But now my digitiser is not recognised.
 
Where can I get a 5152 digitiser driver(NI SCOPE) that works for LV7.0 also.(I was unable to find one from NI website. They all needed LV7.1 or later)
 
I am using a PXi system with PXI - 8175 controller.
 
0 Kudos
Message 1 of 5
(2,956 Views)

One more thing..The newer versions of NI SCOPE that support PXI 5152 also need newer versions of DAQMx that does not support LV7.0.

It would be helpful is some one can some one point me to the latest version of DAQMx that supports LV7.0 and a corresponding NI SCOPE version that supports 5152

I was unable to identify a correct combination that worked for me!..

 

0 Kudos
Message 2 of 5
(2,955 Views)

Hi,

 

I went through a couple of NI-SCOPE readmes and the latest version I was able to find that will be compatible with LabVIEW 7.0 would be NI-SCOPE 2.8.1. NI-Scope 2.8.1 - Windows 2000/NT/XP.

 

I hope ot helps

Jaime Hoffiz
National Instruments
Product Expert
0 Kudos
Message 3 of 5
(2,926 Views)
This is a duplicate of this thread http://forums.ni.com/ni/board/message?board.id=150&thread.id=1821 which is in the High Speed Digitizers forum.
0 Kudos
Message 4 of 5
(2,924 Views)

Hi,

Sorry I did not realize you had a PXI-5152 and like it was posted by one of my co-workers the PXI-5152 will only be supported on NI-Scope 3.2 or later.  The NI-Scope 3.2 requires LabVIEW 7.1 or later.  In this case you options are like Sam said upgrading LabVIEW or getting a new digitizer.

From the list you posted on the previous thread you should be looking at: LabVIEW 8.5 Compatibility Information. For your timing and your DAQ device we can check the driver in this website: NI-DAQ Driver Support: PCI/PXI Devices .

Now for the PXI-8175 we need to take a look at the minimum requirements for LabVIEW 8.5 and the best place to search for this data would be here: Release Notes.

I hope it helps

Jaime Hoffiz
National Instruments
Product Expert
0 Kudos
Message 5 of 5
(2,914 Views)