LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to connect furness controls FCO510 micromanometer to PC via RS232

Solved!
Go to solution

Hi all,

 

I am a newbie at using Labview and any NI products for data logging. I am currently undertaking research to gather data in real time from a Furness Controls FCO510 Micromanometer to perform some analysis of an annular diffuser duct used in gas turbine exhausts. I followed the user manual provided by the company but did not get any results. At first I tried Hyperterminal and then Labview, failing both times to receive any input back from the manometer at all. Also, I am not able to recover any logged data from the micromanometer.

 

Can anyone give me any hints or guide me as to what should be done to resolve this issue.

 

Thank you.

0 Kudos
Message 1 of 17
(5,048 Views)

Good to see that you have tried Hyperterminal.

 

Is your cable correct and in Hyperterminal did you set the COM port settings to match the instruments settings (baud rate, data bits, parity, stop bits)?

 

-AK2DM

~~~~~~~~~~~~~~~~~~~~~~~~~~
"It’s the questions that drive us.”
~~~~~~~~~~~~~~~~~~~~~~~~~~
0 Kudos
Message 2 of 17
(5,037 Views)

When interfacing a new instrument- find a command that requires no response- ideally a reset command- and FIRST figure out how to send that.

 

 

This assumes, of course, that you can tell if it has responded to the reset command.

 

Often that first step of establishing communication can be a real bottleneck.  

0 Kudos
Message 3 of 17
(5,035 Views)

Baud rate = 9600

parity = none

 

I have left the other settings to default. The cable is a standard RS232 from the market.

0 Kudos
Message 4 of 17
(5,019 Views)

RS-232 can be tricky. Note that there are at least two "standard" cables, a regular (direct connect?) and a null modem cable. If one doesn't work you might want to try the other.

 

0 Kudos
Message 5 of 17
(5,013 Views)

Hi,

 

I had a similar problem a while back in that I couldn't connect to something via the RS232 port on the PC (either through Hyperterminal or LV), when I put the signal through a RS232 to USB converter it worked first time and as expected.

 

Maybe there are some settings in Windows that can be changed but I had the converter sat on my desk and once it worked I couldn't be bothered to check...!

 

Take it easy,

 

Darren.

0 Kudos
Message 6 of 17
(5,011 Views)
Solution
Accepted by topic author ukbaisdumb

I have found the solution. As indicated I need a null modem cable with handshaking. So I made one on by connecting in the following way:

FCO510                      PC

Tx<==========>Rx

Rx<==========>Tx

GND<========>GND

7<=I

     wI

8<=I

 

all other pins left untouched.

 

thanks to ur help guys!

0 Kudos
Message 7 of 17
(4,962 Views)

Hi,

 

I am also stuck up with same problem,

 

Can u attach the example code & wiring diagram for RS-232 cable.

 

That will help me.

 

Thanks & regards,

 

S. Senthil Prakash

 

Research Associate

 

FCRI 

0 Kudos
Message 8 of 17
(4,743 Views)

hi

 

for the rs232 cable (pc end) short 7&8,  6&4 pins.

 

source: furness controlsss 🙂

 

thanks

 

mama miya

0 Kudos
Message 9 of 17
(4,677 Views)
I have the same problem. I have the correct cable and can write data to the FCO using matlab but can not get it to work from LabView. The port the FCO is connected to does not register anything in Windows Device Manager. Can anyone help?
0 Kudos
Message 10 of 17
(3,252 Views)