LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to Custom sort vi's in a project

Dear National Instruments,

The following help page sorely needs information added:

http://zone.ni.com/reference/en-XX/help/371361P-01/lvhowto/organizing_items_project/

 

It tells me that I can select a custom order for the VI's to be displayed, but it does not actually tell me how to order them! And when I set my project or folder to custom order, and then try to drag VI icons up or down the list, it gives me a "prohibited" cursor symbol, and I can find no way to do it.

 

Having chosen custom order for a project, how do I actually order the items?

0 Kudos
Message 1 of 6
(508 Views)

Have you ever heard of "Drag and Drop"?  If your VIs in the Project Library are in the order A, B, C, D (the default Sort-by-Name), and you click on C and drag it up one position and let go, the order will be A, C, B, D.

 

Now, why you would want to do this is unclear.  Projects and their Libraries can grow to the hundreds, which puts a boon on a sensible order such as "alphabetical, by Name", i.e. the Default.  I recommend you wait at least a year doing serious LabVIEW Development before you get upset with NI for the documentation of Custom Order in the Project Library.

 

Bob Schor

0 Kudos
Message 2 of 6
(483 Views)

Yes I get drag-and-drop, it was the first thing I tried. But every time I try the cursor changes to a black circle with a slash through it, the universal "prohibited" symbol. Quite repeatable.

 

My custom order is logical: it's top-down. I like to put the top level VI's and their immediate subroutines at the top of the list, where I can find them quickly.

0 Kudos
Message 3 of 6
(457 Views)

Well, I must confess it's been a long time since I tried "hand-sorting" the Project Explorer listings.  I didn't recall the "Prohibited" symbol, but you are correct, in LabVIEW 2016 and 2018 (the two I tested), it is, indeed, present when you attempt to Drag and Drop.  I normally have the entire Project sorted "by Path", but find that if I ignore the Prohibited symbol, I can, indeed, Drag and Drop to rearrange as I wish, and the "Arrange by" will automatically change to Custom.

 

What version of LabVIEW are you using?  It does appear that the versions of the past few years permit what you wish to do.

 

Bob Schor

 

0 Kudos
Message 4 of 6
(450 Views)

I'm using 2017, and it gives me the prohibited symbol and it actually won't let me change anything. Is this an issue related to using auto populating folders? Because I do. But whether I drag a file or folder, it won't.

0 Kudos
Message 5 of 6
(434 Views)

Ah, yes.  I always turn off Auto-populating, as it "locks" the Project (it basically says "Make the Project slavishly follow the position of the files on the disk").  That is definitely the culprit (I'm embarrassed not to have thought to suggest this ...).  If you must use Auto-population, then you should turn it off (temporarily), move your files from within Project, not in Windows File Explorer, with LabVIEW not running, then turn Auto-populating back on.  Or leave it off ...

 

Bob Schor

 

P.S. -- when Auto-populating is off, you may have difficulty seeing the correspondence between Physical Folders (on your disk) and Virtual Folders (within your Project).  In the Project Explorer, under the Project Menu, you can turn on "Show Item Paths", which show the Physical Folders, and lets you see how they "match" with the Virtual Folders.  I use this to make sure files are where I want them to be.

0 Kudos
Message 6 of 6
(431 Views)