LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I specify the Startup VI for a LLB in LV 8.5.1 Full?

Solved!
Go to solution
Highlighted

Hi,

 

I recently upgraded to LabVIEW 8.5.1 from LabVIEW 7.1.1.  I entered the project Build Specifications and compiled my code into a LV .llb file called "my_program.llb".  I also specified the top level vi (called "main.vi") inside my_program.llb.  Now I want to make "main.vi" automatically open and execute whenever the user double clicks on my_program.llb from within Windows Explorer. How can I do this in LV 8.5.1 Full?

 

Right now when the user double clicks on my_program.llb, the LLB Manager window opens, but "main.vi" doesn't automatically launch like it used to do back when I was using LabVIEW 7.1.1 Full.

 

I know it is possible to specify the Startup VI using the Professional version, but is this possible to do in the Full version?

 

Thanks,

Richard

 

0 Kudos
Message 1 of 4
(1,292 Views)
Highlighted
I recall seeing a post talking about this, but not enough details. You need to go into one of the LV setting files and change a key value. That's all I know. I will be interested in knowing the answer as well.
0 Kudos
Message 2 of 4
(1,259 Views)
Highlighted
Solution
Accepted by topic author RichardBallantyne

Check out this KB

Managing LabVIEW Library Files in Windows Explorer & the LLB Manager

 

...

LabVIEW 8.5 and beyond
In LabVIEW 8.5, the option to open LLB files in Windows Explorer has been removed. However, if you have a previous version of LabVIEW installed along with 8.5, LLBs can still be opened through Windows Explorer if you follow the procedure below. If you are not using another version of Labview along with 8.5, you can change the default behavior so that an LLB that is opened from Windows will open the top-level VI instead of the LLB in the LLB Manager.

...

 

 

Message 3 of 4
(1,246 Views)
Highlighted

That worked!  Thanks very much.  BTW, in case anyone wants to know, here is what I did:

 

  1. Locate and open the LabVIEW.ini file located in the same directory as LabVIEW.exe (usually at C:\Program Files\National Instruments\LabVIEW 8.5)
  2. Add a new line anywhere in the file with the text: useLLBManager=false
  3. Save and close the ini file
  4. Restart LabVIEW

Cheers,

Richard

 

 

Message 4 of 4
(1,231 Views)