LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I run a thread without its panel.

I have created a vi in my application that I run as a thread. I run the thread by using an invoke node.

When I am testing under LabView everything is fine but when I create the executable I have found problems.

As I am starting the thread with an invoke node, the vi does not show in the application builder unless I add it as a top level vi. When I add it as a top level vi, the panel is shown when I run the application.

I don't want to show the panel because firstly theres nothing on it anyway and secondly it looks untidy.


Dave.
0 Kudos
Message 1 of 5
(1,294 Views)
Did you try adding the vi using "Add Dynamic VI" in the application builder? If you add it as a Dynamic vi instead of a top level then you should be able to run it without displaying its front panel. Hope this helps, let us know if it doesn't.

Brian
0 Kudos
Message 2 of 5
(1,294 Views)
Brian

I tried that already with no effect. I have attached an example of my problem. This shows a meter on the front panel. A vi running as a thread writes a value to a global every 20ms and this is then read by the front panel and written to the meter.

Dave.
0 Kudos
Message 3 of 5
(1,294 Views)
Find attached Front Panel.VI modified.
I inserted a property node to set the FP visibility.

let me know if it's not working.
Message 4 of 5
(1,294 Views)
Include the VI as a dynamic VI and change its settings to save the front panel. By default, front panels of dynamic VIs are not saved, and the panel is required to run the VI Top Level.

Jean-Pierre Drolet


LabVIEW, C'est LabVIEW

0 Kudos
Message 5 of 5
(1,294 Views)