Showing results for 
Search instead for 
Did you mean: 

How can I prevent the text in non-resizable contexts from being cut off?

I have not changed the Application, System, or Dialog fonts from their defaults.  


This is the result:


squished lines.PNG


squished lines timing box.PNG



0 Kudos
Message 1 of 8

Something is off.  What are the settings within Windows itself you are using?  Do you happen to have the "large fonts" or "extra large fonts" selected within you display appearance settings  (right click on desktop and pick properties, then appearance tab)?  Or is it set for "normal"?

0 Kudos
Message 2 of 8

I verified that "medium" (the default) is selected.


I also checked to see if switching to "small" fixed it.  It does, but this is far too small for work.

0 Kudos
Message 3 of 8

What OS are you using?  On XP, I don't have a "medium" selection.  Only "Normal", "Large", and "Extra Large".  I'll find a Win7 machine soon to see what choices it gives.  I remember an older machine, I don't remember the OS, that seemed to only have 2 choices, Normal and Large, and I think Large was 125% of normal.


I think you will have to use the Normal size setting.  And if that is too small, then reset your overall screen resolution to something larger.  I agree it isn't ideal, but a lot of things in LabVIEW don't play well with that setting be different than however the dialogs and windows were originally designed.  Features that need to scale with the larger font just don't.


I had an argument once with our IT guy about that setting, and he said if the fonts are too small to read, then I should use a lower resolution (i.e. lower numbers for width and height).  That sounds good on the surface, except for those many applications where you want a high resolution to get more screen real estate (such as AutoCAD, FEA, and of course LabVIEW).  I want more pixels to be able to show more things, but I don't want the resulting pixels to be so small I can't read what should otherwise be normal fonts.


While I say the things in LabVIEW don't play well, I really blame the OS and Microsoft for not providing a mechanism for handling this better.  They have a font setting for Windows whose actual size is heavily dependent on the resolution, but won't let you make basic text larger to read within a given resolution without breaking a lot of other things.

0 Kudos
Message 4 of 8

Medium might be the default for high ppi monitors but it is very different from the original windows settings that were used when 96 ppi was standard. Of course for a high resolution FullHD resolution on a 15 inch screen you end up with a ppi of around 150ppi.


This article explains somewhat the history of where 96ppi came from and that it was in fact already a convinient misrepresentation of the real values. The problem is partly that LabVIEW makes some assumptions about the size of text based on the actual ppi settings while the rendering of the text as done by Windows can be scaled by your control panel adjustment. However the solution is not as trivial as replacing all assumbtions about the size of text by the new values as that won't always give the correct values either and also has quite a lot of other issues such as controls suddenly looking very oversized when moving a front panel from a low ppi device to a high ppi device. Basically the way Windows deals with screen resolution and different ppi makes it simple for Windows to render text on a display without ugly aliasing effects but makes it impossible for an application to both be text and size accurate when rendering windows like a LabVIEW front panel.

 It's also a reason why so called retina displays still don't really work under Windows while IOS has them already for quite some time.


Ravens Fan, Windows 7 has Normal (100%), Medium (125%) and Larger (150%). To maintain the relative text size on an old CRT for a FullHD 15 inch labtop display one would have to use the Larger setting, which is outright ugly. I personally use Smaller on all my Windows 7 labtops because of issues like the LabVIEW front panels rendering but also many other applications get into trouble otherwise. Yes it looks kind of small on my FullHD 15 inch LCD monitor, but at least it is all consistent.

Rolf Kalbermatter
Averna BV
Message 5 of 8

Thanks Rolf,


I finally had a chance to look at my Win7 laptop, and it only gives 2 choices "Smaller - 100% (default)"  and "Medium - 125%"


I also see a link for "Set custom text size (DPI)" that has 4 choices in a dropdown (100, 125, 150, 200%), lets you pick anything in between (and up to 500%) if you drag a ruler on the screen.


It also has a checkbox (checked on mine) that says "Use Windows XP style DPI scaling.


Whatever all that means.  I find it best not to mess with any of it.

0 Kudos
Message 6 of 8

Most likely your notebook has either a lower resolution than FullHD (1920 * 1080) or a bigger screen than 15 inch. Windows 7 only shows the resolution steps up to whatever your display has.

100% = 96 ppi, 125% = 120 ppi, 150% = 144 ppi


The latest is about the ppi that a 15" FullHD monitor has

Rolf Kalbermatter
Averna BV
0 Kudos
Message 7 of 8

1366 x 768 is the max resolution,  So that makes sense.  I think it is a 15" screen in the 16 x 10 format.

0 Kudos
Message 8 of 8