LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How can I add a PNG file to a report?

Solved!
Go to solution

Hello,

 

   I am trying to add a PNG file to a report using the append image vi and I am getting errors. Is this the correct vi to use?

Regards,


Kaspar
0 Kudos
Message 1 of 12
(1,703 Views)

I tried Append image to a report vi, and it works without any problem, I used a png image. You have to wire the path of the image, and you should mention the MS office parameters.

 

Post your vi if it is possible.

0 Kudos
Message 2 of 12
(1,698 Views)

Hello,

 

  Thanks for getting back to me. The file I am trying to append is a existing PNG (Portable Network Graphics) file, that does not have any MS office parameters. The vi I am trying to use is the Append Image to Report vi from the report tool kit, so I am confused about the "MS office parameters". I am using Labview 8.2 on Windows XP Pro.  Here is the error message I am getting

 

Error -2147352567 occurred at Unable to load picture. in Append Image to Report.vi->create_scan_report.vi

This error code is undefined. No one has provided a description for this code, or you might have wired a number that is not an error code to the error code input.

 

 

Here is the text from the help of the vi that describes how to specify the image

 

path or URL of image designates the URL of the linked image. If you intend to post this page to the World Wide Web, use forward slashes (/) in paths. If the images are on your local computer or on a network, use backslashes (\) in the paths. If you move the images, you must update the links.

 

 

Any ideas out there?

 

Regards,


Kaspar
0 Kudos
Message 3 of 12
(1,687 Views)

The MS Parameters input parameters input is not related to the image you are trying to append to the report, it is related to where you want to append the image in the report, for example, if you are using an excel report, you have to set at which location in the excel file you want the image to be appended. In the image below the image will be appended in row 2 and column 3

 

Untitled.png

 

Hope this helps

0 Kudos
Message 4 of 12
(1,683 Views)

If you can post your vi or an image from it, it will be helpful,

also, what is the type of the report you are trying to generate? Excel, word ?

0 Kudos
Message 5 of 12
(1,680 Views)

Hello,

 

  Attached to the replay is a PNG file of the section of the code. There are only 2 kinds of reports that I can create, a "standard report"  or a "html report". Hopefuly this provides info to allow someone to tell me how to fix this.

Regards,


Kaspar
0 Kudos
Message 6 of 12
(1,667 Views)
0 Kudos
Message 7 of 12
(1,659 Views)

Hello,

 

  I do have the extension defined in the file name, the file name is Cscan.png. 

Regards,


Kaspar
0 Kudos
Message 8 of 12
(1,656 Views)

It seems you are not giving a path or URL for the path input of the Append image vi, you are giving the name of the image with any path, right click on the path constant, select "Browse for Path", then go the path in which you have the image you want to append.

0 Kudos
Message 9 of 12
(1,644 Views)

Hello,

 

   You are correct, the path of the file in the prior append just contained the file name. Prior to creating the file I removed the long path to the file name because it was a long path to a shared drive. I have tried a bmp file and it works for me, However I cannot append png file to a report. I will keep trying various combinations of file types and/or sizes to getting a better understanding of what is going on.

Regards,


Kaspar
0 Kudos
Message 10 of 12
(1,635 Views)