LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Histogrammeinstellungen

Hallo,
 
wie kann ich vom Frontpanel aus Einstellungen an der Klassenbreite bei Histogrammen vornehmen? Ich verwende LabVIEW 8.20 und über das ExpressVI Histogramm werden die Klassenhäufigkeiten als Stab- und Liniendiagramm ausgegeben. Nun will ich über das Frontpanel die Klassenbreite verändern können, während das VI ausgeführt wird. Kann ich minimale Klassenbreiten definieren?
 
Vielen Dank im voraus.
0 Kudos
Message 1 of 8
(1,087 Views)

As far as my German goes, I think you're asking for a way to programmatically change the settings of the "Create Histogram" ExpressVI. What you have to do is right-click on the ExpressVI icon and select the German equivalent to "Open Front Panel" - it's probably called "Frontpanel öffnen". That will change the ExpressVI to a regular SubVI and you can then edit its input and output terminals. Here's the Create Histogram after I converted it to a subVI and added the three additional inputs:



I hope that it answers your question.

Message Edited by Philip Courtois on 01-09-2007 05:10 PM

- Philip Courtois, Thinkbot Solutions

Thinkbot Solutions
Message 2 of 8
(1,070 Views)

Thanks a lot, now I have the next Problem, after changing the ExpressVI to a regular SubVI the Minimum and Maximum value is always 8 when I open the VI.

What can I do, if I don`t want to edit these values every time I open the VI. I want to define standard values for the Maximum, the Minimum value and the number of Bins. I only want to give the possibility to edit the number of bins on the frontpanel.

Thanks a lot for answering.

0 Kudos
Message 3 of 8
(1,056 Views)
Couldn't you just create a front panel numeric control for each value you want to control and then wire these controls into the Sub-VI you just created?
0 Kudos
Message 4 of 8
(1,042 Views)
That`s no problem to creat numeric controls and wire them with the SubVI, but that`s not what I want. Because I have many other graphs and numeric controls on the Frontpanel. The Minimum and Maximum value is always the same. It`s not necessary to change it for every measurement I do with my VI. If I solve the problem on this way I have every time I measure too many values to edit. In the Express VI Histogramm I could set the Minimum and Maximum values I want, but after converting it to a SubVI every time I open the VI there are values for Min and Max I can`t use. Perhaps the problem is only in storing the SubVI, I don`t know.
 
0 Kudos
Message 5 of 8
(1,036 Views)
Open the subVI once more, fill all controls with the desired default values, then go to "edit...make current values default". Save the VI again. Smiley Happy
 
Whenver you leave an input uwired, the default will be used.

LabVIEW Champion Do more with less code and in less time
0 Kudos
Message 6 of 8
(1,022 Views)

As you can see in the attached screenshot I can not set the current values as default values.

 

 

0 Kudos
Message 7 of 8
(1,005 Views)
Hmmm, never seen that. Are you operating on a sytem VI or did you save it under a new name first?
 
In any case, try "ctrl+m" to go to edit mode first and see if things improve.

LabVIEW Champion Do more with less code and in less time
0 Kudos
Message 8 of 8
(996 Views)