LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Having trouble finding devices on PXI-1033

Solved!
Go to solution

When looking at the devices in Measurement and Automation Explorer my NI PXI-7853R and 128Mux (PXI -2532) seem to be working just fine. However, when loading a Labview FPGA project the new project wizard displays the error:

 

No PXI controllers were discovered on the network.  Ensure your PXI controller is properly configured in MAX and try again.

 

uising the the "R series Intelligent DAQ on Real Time PXI" option.

A similar promblem arises when using NISwitch it simply cannot find the PXI 2532.

 

With labview I was able to, using an example an example, reassociate the device and get it to compile a run under an existing project.

However, to my knowledge, there is no way to do this with NISwitch.

 

I've tried to fix the issue by restarting the computer several times. Also tried to reinstall the NI Switch drivers as well, with no luck

0 Kudos
Message 1 of 9
(2,387 Views)
Solution
Accepted by topic author Jayem

Hi Jayem,

 

It seems like you have a couple different things going on and possibly multiple systems.  Can you please provide more detail about your concerns and setup(s)?  Where in the FPGA project creation (http://zone.ni.com/devzone/cda/tut/p/id/6358) do you receive the error?    

Regards,


h_baker
National Instruments
Applications Engineer
Digital Multimeter Resources
Message 2 of 9
(2,360 Views)

Sorry I accidently clicked the solution button.

 

To be more specific the problem arises at the end of step three of the URL provided above.

Also, I have now tried reinstalling labview over the top of the current installation and the problem still occurs.

0 Kudos
Message 3 of 9
(2,349 Views)

Jayem,

 

You say you see your two PXI cards in Measurement and Automation Explorer, but do you see the controller listed under Remote Systems?  Also what controller are you using?  Is it a Real-Time controller or Windows?

Message 4 of 9
(2,321 Views)

http://sine.ni.com/nips/cds/view/p/lang/en/nid/202984

This is the PXI 1033, I believe it has an integrated controller and we have the single port PCIe card. I'm not sure about the Real-Time controller in Windows.

In order circumvent the issue I have installed all the necessary software on another computer with a fresh install of windows and it seems to be working great, so my thought is to remove all labview software and reinstall labview and related software or possibly even reinstall windows.  

0 Kudos
Message 5 of 9
(2,308 Views)

Hi Jayem,

 

In the FPGA Project Wizard, what Project Type are you selecting?  Are you selecting "R Series Intelligent DAQ on My Computer" or "R Series Intelligent DAQ on PXI Real-Time"?  The second is for a PXI Real-Time controller; in your case, you would need to select the "My Computer" option.

Message 6 of 9
(2,296 Views)

Kyle,

I appreciate your help.

 

The PXI-1033 is a PXI controller separate from my computer (connected via a cable to a card in the PCIe slot of my computer), so I believe that the second option you mentioned is the correct one.

As I tried to convey earlier the set-up is working just fine on another computer, so I've given up on trying to make it work on the other computer.

Thank you all for your help.

-Jayem

0 Kudos
Message 7 of 9
(2,288 Views)

Hi Jayem,

 

The PXI Real-Time Option is not correct for your case, because you are not using a Real-Time Operating System on your PXI controller.  The first option should work correctly for your case. 

0 Kudos
Message 8 of 9
(2,285 Views)

Kyle,

 

You're right, the other option isn't even given on the PC I am currently using. The wording is somewhat misleading to me.

 

Thank you,

Jayem

Message 9 of 9
(2,274 Views)