LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Graphic value of system button in cluster is not updated in LabVIEW 2018

When value of a system button is updated by property node or local variable the graphic of the button is unchanged until the window is redraw, eg. by changing the size of the window.

 

It looks like bug of LV18, in LV16 its ok.

Download All
0 Kudos
Message 1 of 9
(1,092 Views)

This is very strange code (which makes little sense, to me).  Are you trying to "synthesize" a Latch when Released (mechanical Action #5)?  Anyway, both of your examples looked the same to me in both LabVIEW 2016 and LabVIEW 2018.  Of course, I was probably not sophisticated enough to find the test condition and observe the "buggy" behavior you found ...

 

What are you really trying to do with this Control and Event Loop?  [Consider not using a Value Property Node -- they are frequently "a mistake" ...]

 

Bob Schor

0 Kudos
Message 2 of 9
(1,043 Views)

@petrz wrote: 

It looks like bug of LV18, in LV16 its ok.


Works just fine in LabVIEW 2018. Buttons immediately reset to FALSE when pressed.

 

(Note that the system button also has a "hover" color, that looks similar to the ON state as long as the mouse is over it. That could confuse some. It would help in clarity if you would configure it for two different strings for the two states.)

 

Since we cannot reproduce it, please provide exact step-by-step instructions of how you are running this, what you do, what you see, and what you expect to see instead.


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 3 of 9
(1,040 Views)

Could of course be a local issue. Combination of LV18\Windows\GPU?

 

My virus scanner thinks it's convenient to switch to game mode when I use LabVIEW (causing graphical artifacts). So it could be introduced by Windows or 3rd party programs. And it could be done to 18 and not to 16...

 

0 Kudos
Message 4 of 9
(1,025 Views)

This VI works fine for me.

What can you tell us about your setup?

 

Also I am using the f1 patch of LabVIEW 2018.

Try patching yours: http://www.ni.com/download/labview-development-system-2018/7561/en/

0 Kudos
Message 5 of 9
(1,018 Views)

Strangely today it works for me. So it's probably one of the mysterious sometime happening bugs. But today I'm working directly on laptop, when it happened I was using a dock station and external monitor.

 

The code is strange because it was written just to exploit the "strange" behavior, I want to eliminate all my fancy stuff. Originally I used something similar to handle buttons in cluster of multiple controls (application settings). I cannot use "Latch when released" because I'm accessing the control by local variable.

 

I'm think wiebe has good point, it may be some combination of graphic display settings, day of week, humidity or something else. I will try again on Monday in office.

 

I'm using LV 18.0 64b. I didn't noticed there is patch available, thanks for notification I will try later.

 

One off topic question.  How do guys get notification about a patch is available? NIPM says nothing, NI updates services seem doing nothing (IMHO NIPM replaces NI update services).

 

 

0 Kudos
Message 6 of 9
(1,001 Views)

The NI Package Manager is only responsible for updating software which was installed with it. This is most probably because of the packages/feeds concept the NIPM is using.
Since LabVIEW 2018 is installed "traditionally" the NI Update Service is taking care of its updates. I can also confirm that the f1 Patch for LabVIEW 2018 is showing in the NI Update Service as a critical update both for the development environment and the run-time.
If you do not have the notifications maybe the automatic update is turned off for you.

0 Kudos
Message 7 of 9
(986 Views)

I tried again on Monday morning in office and button worked OK. Then I tried later after noon and it happened again, but in this case was unable to fix, I restarted LabVIEW, undock laptop, restart Win nothing helped. Today I trying again and guess what, it works ok. Since I don't know how to reproduce this behavior, I don't think you can help me. I going to install the LV patch and I will see in future what will happen. I'm attaching the  video of the behavior if someone want to see. I'm giving up :), classic buttons works OK.

 

Btw: The patch LV is in NI update manager, but it took about 20 min to get list of updates. It always returned message about NI server unavailable.... I had disabled automatic updates check, so my fault.

 

 

0 Kudos
Message 8 of 9
(963 Views)

I would definitely also check if there is an updated driver for your graphics card. Could be a plain bug, but maybe it simply does not cleanly switch over when the laptop is docked or when it switches from power to battery or vice versa. Also look at the power settings.


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 9 of 9
(948 Views)