LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Get TestStand Application Manager

Hi everyone and happy new year ! May all your codes work fine ^^

 

My problem is about LabVIEW communicating with TestStand.
I want to retrieve on LabVIEW the Application Manager of TestStand.
The point of that is to create a TestStand UserEvent to communicate with TestStand with UIMessage and get data from running sequence.

 

My LabVIEW code is going to run as an executable so I just can't get the Application Manager on TestStand, then call my code through the LabVIEW adapter and give it the ref of the Application Manager just as below :

TenJigoku77_1-1609863875103.png

 

I tried to pass the Application Manager as a arguments with the step "Call Executable" but it didn't work (I can only pass strings and the type cast doesn't work) => Maybe I miss something, if so, just tell me ^^ 

 

In the end, I tought maybe there is a way to retrieve the currently running application manager with a property node of the TestStand API but I didn't find it.

 

Does someone have a clue for this probem ? Any tips would be fine too.
Thanks in advance and see you soon (I hope ^^) !

0 Kudos
Message 1 of 3
(145 Views)

Hi TenJigoku77,

 

What do you mean by "it didn't work"? Did you get any error?

By looking at your screenshot, I think that maybe there is a mismatch between what you get using the ActiveX steps and what your LabVIEW code module is expected.

Can you send a screenshot of the step settings of the ActiveX Action steps?

 

Thank you!

Clement

0 Kudos
Message 2 of 3
(73 Views)

Hi Clement,

Thanks for your answer.

My activeX module is working fine, I really get the application manager, I can pass it to a LabVIEW module and normally use property and invoke node.

But don't want to use a LabVIEW module because it has many dependencies (risk for the user to delete files) so I prefer launching an .exe.
So I decided to compile and launch this .exe with input command lines :

I tried to cast the application manager into string in order to pass it in command line. But when I read the command line in the .exe, cast it into the object "application manager", then use property node or whatever it send me an error ("the object is not a valid ref...").

This is what I meant with "it didn't work" => I can't transfer the application manager from teststand to a LabVIEW exe (I tried with files).

Regards.

0 Kudos
Message 3 of 3
(69 Views)