LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Get Error 6 about 50% of time when building Application

I also had this problem, intermittently.

 

I believe the source of the problem on my Windows 7 machine was drop box.

When I pause synching, the problem seemed to go away...


-Mike

0 Kudos
Message 41 of 54
(1,143 Views)

Thanks for the Hint.

 

If Labview is designed properly, other system activit should have no effect on the Build process as long as the system meets the minimum requirements to run Labview..

0 Kudos
Message 42 of 54
(1,133 Views)

Update from my side.  I thought disabling the Dropbox sync was the answer.

 

I was wrong.  I still get the error about half the time, as others have reported.

I can live with this, since it only takes a few tries to get a successful build.

 

But I am dreading the day when I won't be able to build.

 

So I am very interested in a fix...

0 Kudos
Message 43 of 54
(1,128 Views)

One more 2 cents' worth: In my case, this error was caused by Windows Explorer being open viewing either the destination folder, or the parent folder of the destination folder. Closing Windows Explorer fixed the problem.

 

An open Windows Explorer did not always ensure the problem occured...but closing Windows Explorer (in my case) always made the Error 6 go away.

 

Machine is 2.8 GHz Core i7 64 bit Win7 SP1

0 Kudos
Message 44 of 54
(1,099 Views)

I second that. Closing the file manager window fixed this intermittent issue for me. Win7-64.

0 Kudos
Message 45 of 54
(1,081 Views)

It is AMAZING that people are STILL getting this error so frequently and it hasn't been fixed YET !!

0 Kudos
Message 46 of 54
(1,071 Views)

@dbaechtel wrote:

It is AMAZING that people are STILL getting this error so frequently and it hasn't been fixed YET !!



I have not seen any issues since upgrading to LabVIEW 2011. Of course it was also on a new Windows 7 install so much has changed. Maybe people still having issues are using older versions of LabVIEW. From what I know of this issue (not a lot) it seems like NI is at the mercy of the Microsoft OS. I have not seen (or looked for) issues on other platforms.

 

Is there anyone else that had issues with builds that went away with LabVIEW 2011?

=====================
LabVIEW 2012


0 Kudos
Message 47 of 54
(1,068 Views)

Thanks Wiredup and Cepera,

 

This is good information for us.  When I was trying to reproduce this one of the things I tried was to have Windows Explorer open or closed.  I don't believe that I could find any correlation to this and the build failures; however, that was a number of months ago.


I could only reproduce this in house if I had a 3rd party indexing program installed.  As Steve mentioned we really are at the mercy of the OS with this problem.  ANY third party program could be reserving the temporary files when we try to delete them.  We tested some retry logic in the delete code and it seemed to prevent the error after only a couple of retries when either Search Everything or Google Desktop were running.

 

Because we couldn't reproduce the error without either of these two I'm hoping it will still help the other cases where this is happening.  Hopefully having Windows Explorer open is what is causeing this.  If so then the workaround is extremely easy for our users.  The fix is not in LabVIEW 2011 as we were still testing and trying to reproduce the error when LV 2011 went final.

 

If others can comment on whether having Windows Explorer open to the build directory has an affect it would be greatly appreciated.

Regards,

Jon S.
National Instruments
LabVIEW NXG Product Owner
0 Kudos
Message 48 of 54
(1,058 Views)

I've had this problem off and on with LV2010 on Win 7 Pro 64-bit. Usually a 2nd build attempt will be successful, but just now I had it fail 3 or 4 times in a row, which is what brought me to this thread. I did indeed have the build destination folder open in Windows Explorer, and closing that window resulted in a successful build on the next attempt.

 

0 Kudos
Message 49 of 54
(1,014 Views)

Previously successfully built my application in LV2011SP1 on WinXP and LV2010SP1 on a separate Win7 system (Quad Core). Recently tried on a different Win7 machine (32-bit Intel Core-2 Duo) and got the Error 6 problem consistently. As soon as I closed Windows Explorer (which was open to my project directory near the build folder) I was able to successfully build.

Chris Walker
Certified Labview Developer
0 Kudos
Message 50 of 54
(989 Views)