LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Front panel centering not working of different resolution monitor.

 

I created a VI on a windows 7 machine with a monitor resolution of 1280x1024.  Under the Vi Properties->Window Size, I checked the "Maintain proportions of Window for different monitor resolutions", and under VI Properties->Window Run-Time Position, I chose "Centered" for Position and "Primary" for Monitor.  I built an EXE.  When I start the EXE on the Labview development machine, it is centered and looks good.

 

I copied the EXE to my laptop with a 17" screen and resolution of 1600x900 (WIndows 8 machine).  When I start the EXE on this machine, the front panel window shows up with part of it off the viewable area to the left.  I am able to move it to the right to see the whole front panel.

 

My question is why wasn't it centered on my laptop and completely viewable like it was on the development machine?  What did I forget to check in the VI properties?

 

Thanks,

Rick

0 Kudos
Message 1 of 6
(855 Views)

Hi RPluth, 

 

Make sure that you also check the box for "Scale all objects on panel as the window resizes." If that doesn't work make sure that you do not have the window maximized on your development machine.

Thomas N.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 6
(820 Views)

 

Thomas N,

 

Thanks for your reply.

 

I do have "Scale all objects on panel as the window resizes." checked, and the window is not maximized on my development machine.

 

When it opens on my laptop (ie. non-development machine) it looks correct size and content wise.  It's just that it's about 25% off screen to the left even though I chose "Centered" for my position.

 

Regards,

RPluth

Message 3 of 6
(809 Views)

Hi RPluth,

 

Can we try checking the box for "Maintain proportions of window for different monitor resolutions" under the Window Size category.

Thomas N.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 6
(788 Views)

Thomas N,

 

I do indeed have that checked, yet still it is off the screen to the left a bit and not centered.

 

Regards,

Rick

0 Kudos
Message 5 of 6
(772 Views)

Hi Rick,

 

Try running this application and let me know if it centers on both computers.

Thomas N.
Applications Engineer
National Instruments
0 Kudos
Message 6 of 6
(747 Views)