Showing results for 
Search instead for 
Did you mean: 

Format NI Flash Drive w/ LabVIEW and LabVIEW NXG for Use as Regular Storage

@beaverpelt wrote:



Did I do it wrong? Should I have moved right to the "format" button within Ufix III somehow immediately after the "restore" completed?

I didn't.  So after performing the restore, I got the same dialog saying replug.  I didn't even unplug at first, I just tried writing to it and it worked.  I could then format it in Windows, or in the Restore utility, and still have the write ability...however now I am seeing a case with even these aluminum ones that I have behave as a write once.  After removing and replugging it is write protected...dang.  And to be fair this sorta makes sense that restoring the firmware that is one the device provides this functionality to NI.


And for Bobs case I guess what this means is you can actually recreate NI's drives for your own software.  Download the things you want using the web installer, and you can provide your activation to just get the tools you want.  Run the Restore which allows you to write once, then copy over the NI installers you want and it will be write protected.  This isn't what I want however which is to have usable drives again that can be written to more than once.

0 Kudos
Message 31 of 40

Sorry, I meant no offense.  I don't have enough "locked" USB Keys (I think the only ones I have are from NI, and I'm happy to keep them for a few more years) to confront "repurposing" them, and worry about running unverified software from the Web.

Bob "Nervous Nellie" Schor

0 Kudos
Message 32 of 40

Found one of 64Gb usb sticks when cleaning my desk and after some digging it can be recycled:


In my case worked fine

0 Kudos
Message 33 of 40

Okay I hate to be this guy, but can you give me a step by step on how you did this?  Because I've used that Phison software multiple times in trying to get these drives to be useful again and the only result was wasted time, and a few bricked devices.  I downloaded Phison MPALL v5.03.0A-DL07, I edited the MP.ini to be the text from that post.  I then started it up. On my Windows 10 PC no devices show up when I click Update.  I tried going into the settings and changing host to 2.0, saved, close, click Update, nothing.


I went to a Windows XP machine (as mentioned in the post) changed to USB 2.0 clicked Update, a device is listed, I press Start, nothing happens, I click Update, the device turns red.  

0 Kudos
Message 34 of 40

Some IT departments disable removable media on their computers.  Maybe this is the case?

(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 35 of 40

@billko wrote:

Some IT departments disable removable media on their computers.  Maybe this is the case?

This is not the case with the computers I was testing on. The drives do show up in Windows, just not in the Phison software on Windows 10.  I did try running as administrator too.

0 Kudos
Message 36 of 40

I used this app on win 7. It detected usb i pressed start and app started to do something (no clue what and how). It took about 5 minutes and turned green. After it works like normal usb stick my win 7 pc. Tried today in office where we have win 10 and usb is clean but write protected. Will check another pc when have the chance.

0 Kudos
Message 37 of 40

I managed to get this to work with my 32GB NI / NI LabVIEW USB sticks, but this would work with most sizes of stick.


Used "MPAL - Phison MPALL v5.03.0A-DL07" from on Windows.

1. Download and unzip

2. Run MPALL_F1_7F00_DL07_v503_0A.exe

3. Plug in NI USB stick, I used a USB 3.0 port

4. Click Settings, then OK to load new settings.


5. Select your controller from the list. E.G. PS2251-03 for my sticks. I used a little heat to remove my USB stick to check the IC on the board, but you MAY be able to lookup the USB device PID/VID online from device manager.


6. I found it would not work unless I selected Host Port 2.0 (then though its connected to a USB 3.0 port!)

Note: Don't enter any value in the Target Capacity box.


7. Click Save, then the X in the top corner to close.

8. Click the Update button.

9. Click Start, then wait a few mins.



10. Any issues, remove and re-insert the USB stick and click update.





Message 38 of 40

This solution worked for me!  This was my drive before flashing (write protection enabled):  (NOTE: the ICVersion)


Before flashing (drive was read only)Before flashing (drive was read only)


After flashing... (drive is now read+write!)

After flashing (drive is now read+write)After flashing (drive is now read+write)

0 Kudos
Message 39 of 40

3 of my drives list the version number as 2251-09, which does seem to be supported.  The other two are 2251-03 and when I click start it eventually goes red with CT-ReadOnlyPage Data 0x6019.  They are doomed to forever be left in my drawer.

0 Kudos
Message 40 of 40