Showing results for 
Search instead for 
Did you mean: 

Failed to copy a distribution


Failed to copy a distribution

I am having a problem with building an installer in LabVIEW 14.0f1 (32-bit).

"Click the link below to visit the Application Builder support page. Use the following information as a reference: >> >> >> >> >>

The following errors and warnings were recorded during the build:

Failed to copy a distribution.
Copying distribution 'NI-VISA 16.0' from: C:\ProgramData\National Instruments\Update Service\Installers\NI_20170627_0839\Updates\NI-VISA 16.0\ to: C:\ProgramData\National Instruments\MDF\ProductCache\
Additional details:
Internal system error.
An internal system operation returned the error "The system cannot find the file specified.".

I have tried resetting the database for NI MAX, recompiling the exe (& confirmed it works), confirmed existence of NI-VISA 16.0, then tried repairing installation of LabVIEW.
Windows 10 Pro; version 1703; OS build 15063.483

Any ideas to try?

0 Kudos
Message 1 of 2

Re: Failed to copy a distribution

My first step would be to completely remove the NI-VISA program from the computer and then reinstall that software. 

Also upgrading your NI-VISA version could be beneficial if there are no compatibility issues with that. I know that your LabVIEW 2014 version is not incompatible.

Also, opening LabVIEW as an administrator and building the installer that way might be beneficial in case your LabVIEW is having a permissions problem finding that file since you manually verified that it existed.

Casey G.
0 Kudos
Message 2 of 2