LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to Start Debug Server


Stephen_S. wrote:

Hi gpww,

 

If you are not able to see your NI Service Locator in your list of services, that is most likely the source of the problem. Make sure that you are not having issues with your firewall and that port 3580 is open. I am looking into using NI Services Locator with a Vista 64-bit system, and will let you know if there are any problems with this.

 

In general, this should only be a problem if you have debugging enabled, as discussed above, and should go away if you disable debugging.

 

Regards,

Stephen S. 


 

 

Hi Stephen_S.,

 

does your answer imply that a compiled VI (with included debug information) can be debugged on a PC where only the LV runtime engine is installed?

 

And if the answer is Yes: how do I start the debugging session then?

 

Regards

 

Franz

0 Kudos
Message 11 of 15
(1,489 Views)

Hi Franz,

 

It is possible to remotely debug an executable that is running on a machine that has only the LabVIEW Runtime Engine installed. Instructions for this can be found in the KnowledgeBase article on Remote Debugging Executables in LabVIEW 8.x.

 

Regards,

Stephen S.

National Instruments
Applications Engineering
0 Kudos
Message 12 of 15
(1,470 Views)

I have checked and my NI Service Locator Isn't running. I have tried to restart it and I get a error saying

 

"Could not start the NI Application Web Server service on Local Computer.

 

Error 1075: The dependency service does not exit or has been marked for deletion"

 

I found a KB that says this:

 

"Note:
Beginning with LabVIEW 2010 the NI Service Locator was integrated into the NI System Web Server. The executable for the web server is located at <National Instruments>\Shared\NI WebServer\SystemWebServer.exe."

 

I browsed to that location, tried to run the application and it says the system web server deamon has encounted an error.

 

Any suggestions?

Doug Ferguson

www.southerndaqsolutions.com
0 Kudos
Message 13 of 15
(983 Views)

I started getting this error after installing the LV2014 runtime engine on a machine running 2012 executables. Setting DebugServerEnabled to false does make the error go away but it also disables debug.

CLED (2016)
Message 14 of 15
(929 Views)

I have the same issues here! I start upgrading from LV2012 to LV2014. But, I saw this error before on some PC, but we just turn the debug flag False.

 

0 Kudos
Message 15 of 15
(901 Views)