Showing results for 
Search instead for 
Did you mean: 

FTP Transfer between PXIe-8100 and host computer


Hello everyone,


I have a program made on LabVIEW 2011 that is deployed on a remote target (PXie-8100 embedded controller). The PXIe-8100 device can be controlled remotely over the network (using embedded web browsing), acquires data as prescribed, and saves the data files to its own C:\ drive. I want to programmatically move these files from the PXIe-8100 to one of several computers that are also on the same network as the PXIe-8100, ideally using FTP transfer. I initially encountered several errors (namely Error 7 and Error 43), but can now run the program without any error messages coming up. However, the desired files are still not appearing on the host computer of my choice. I checked to make sure an FTC server was open on my computer (Windows 7), and this appears to be the case.


In order to debug the problem, I've written a sequence structure with all 4 wiring possibilities as to how the file can be transfered (attached as IMAG1464.jpg). is the IP address of the remote target, is the IP address of the computer I want to send data to, c:\new_data.txt is the file on the RT device I want to have transferred, and c:\Users\Public is the destination on the computer I want the file to be placed in. Whenever I connect the computer's IP address to the "host" port on either of the Put or Get (i.e. panels 2 and 4 of the aforementioned sequence structure), I get an error saying:


"Error 1 occurred at TCP Write in NI_InternetTK_FTP_VIs.lvlib:FTP>NI_InternetTK_FTP_VIs.lvlib:FTP [QUIT].vi->NI_InternetTK_FTP_VIs.lvlib:FTP Close>NI_InternetTK_FTP_VIs.lvlib:FTP Put Multiple Files and>NI_InternetTK_FTP_VIs.lvlib:FTP Put>

Possible reason(s):

LabVIEW:  An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @."


Whenever the RT's IP address is connected to the "host" port on the two subVIs, I get message 221 (no error).


I've attached the relevant VI of this real-time project, as well as a screenshot showing the part of my code where I deal with the FTP transfer. I am unsure of how to proceed with this.... Any assistance with this (or possible alternatives) would be greatly appreciated!

Download All
0 Kudos
Message 1 of 3

I realized I made a slight typo: I meant to say "FTP" rather than "FTC" in the title!


Edit: just realized I can modify old posts..... Sorry about the resulting double post - I'm fairly new here.

0 Kudos
Message 2 of 3

Hallo, I had to work with FTP transfers in "traditional mode" (now WebDAV is used) some months ago so maybe my considerations could not be useful.

But I remember two things that I discovered and that solved some issues.

1. In the Get File vi there is a flag "Active" which is set at TRUE as default. I had to put it to False to achieve communication with my PXI;

2. I had also to open the Get File vi; insite it has a  "get multiple files vi": I opened it and saw that the local port was default set at 0 instead of 21. I had to modify it s default to 21 then save.

these two actions solved for me in that situation... not sure these will work for you but I hope so.

Let me know.. bye


0 Kudos
Message 3 of 3