Showing results for 
Search instead for 
Did you mean: 

FPGA module 2015 on windows 10

Go to solution
Hello all,

I am using FPGA module 2015 and labview 2015 (32- bit) on a 64-bit windows 10 laptop. According to the white paper ( ) the FPGA module version should be supported. However, I can not get the FPGA VI to open and only get an error.

I am trying to run an FPGA target in the simulation mode. The VI was created on a windows 7 laptop.

Is there a possible way to open FPGA VIs on windows 10 ?

Thanks in advance.
0 Kudos
Message 1 of 4

Hello hazem93,


What exactly is the error message and code you are receiving? Do you have the correct drivers installed for your hardware (e.g. the NI CompactRIO or R Series Multifunction RIO device drivers)?


Does opening example LabVIEW FPGA projects cause the same error? Is it just a certain VI or project that is throwing the error?


Thank you,


Alex C.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 4

Hello AlexAlligator,

Yes, I can open the whole FPGA project and even create new FPGA VIs with no issues.


For the drivers: On the windows 7 laptop, I was using myRIO-1900. On the windows 10 laptop I only have  myRIO toolkit (which I assume does not contain the drivers). However, I do not intend to compile or burn the code on the platform, I only need the VI to open and run in simulation mode.


Concerning the error codes, I get the (upper) message initially and after a few unsuccessful trials I get the (lower) one.


I think the error is due to the OS change, but I am not sure how to make the VI compatible to windows 10.




error 2.PNG


0 Kudos
Message 3 of 4
Accepted by topic author hazem93

Solved! The errors have nothing to do with windows 10 or the FPGA module. The VI I exported from the windows 7 laptop was actually corrupted and was saved as so.


Though the VI is still running on the windows 7, it seems that some memory parameters were not exported right and this caused the problem on the new laptop.

Message 4 of 4