Showing results for 
Search instead for 
Did you mean: 

FPGA error: invalid or corrupt bitfile

Hello Henry,


Firstly, you should be able to use a FPGA project and compiled bit file from one device to another by changing the IP, so long as you are certain there are no changes in the device type or the module positions in the chassis. As for your description of what is working versus what is not, I'm not quite sure if I follow where exactly you are running difficulties. From what I can gather from your posts is that you are unable to run the VI's you have developed in interactive mode, whereas you are having success when opening the reference to your FPGA from your host VI on your development system. If I'm mistaken in my understanding of what you were describing please let me know and I might be able to better assist you in isolating this issue.


One question I'm interested in is the following, are you observing this FPGA error: invalid or corrupt bitfile when running any FPGA VIs from the NI Example Finder?



Blayne K

0 Kudos
Message 11 of 23

You have it correct!


I have since run more tests and there are some unusual behaviors coming from the FPGA. I have not yet identified precisely why. One problem appears to be a stuck value coming out of a filter.. When I simulate a fault in one of the modules the output from this filter does not return to zero until the system is restarted. This is something new.Not being able to run the FPGA vi interactively makes debugging difficult.


I am under a lot of time pressure and have not had a chance to try a sample vi. After I put out the current fire I will give this a try.



0 Kudos
Message 12 of 23

Uninitialized shift register maintain its values between calls to that VI?

0 Kudos
Message 13 of 23



 I realise this is an old post but I am having the same problem as that in the first post - have always been working in the same project with a sbrio9606 that is connected fine but when I call to run my FPGA code through an RT host VI I get an error message -61070


Error -61070 occurred at an unidentified location

Possible reason(s):

LabVIEW FPGA: The compiled bitfile for the specified VI contains information that is no longer valid or is corrupt.

Recompile the VI to correct this error.


Attempts to re-compile or move to a new project in the way suggested in previous posts has not worked. Like the previous post I can run the top level FPGA VI on it's own in interactive mode.


The VIs I am attempting to use are those in the LCD Character Display Driver, found here


I would be grateful for any suggestions on how to fix this.


LabVIEW 2012, Win7





0 Kudos
Message 14 of 23

Hi firdauskhalid,


Are you able to get other applications working that do not use the LCD Character Display Driver? Also, it may be useful to get a MAX technical report and I have provided a link on how to do that below. Lastly, if the project is simple enough you are welcome to zip the files together and post it here and I can take a look.


MAX Technical Report:

Patrick H | National Instruments | Software Engineer
0 Kudos
Message 15 of 23

Thanks for the reply Patrick.


Yes, I have been using the rio to program i2c and it work except for this lcd. I am sending you my project file and the technical support file for you to have a look. Thanks for the help.



Download All
0 Kudos
Message 16 of 23

Hi firdauskhalid,


After looking at your max technical report it looks like everything is installed correctly. I also took some time to download the toolkit and look things over. I did notice that there is an example project that comes with the library. Can you try compiling the example? 

Patrick H | National Instruments | Software Engineer
0 Kudos
Message 17 of 23

Bumping this thread again.


I just upgraded to LabVIEW 2013 with Xilinix 14.4 Compiler and my ability to compile useful bitfiles for my FPGA device seems to have vanished.


I have a developmental Windows 7 computer connected via ethernet to a PXI chassis with a PXI-7853R FPGA card. I have made what I believe to be just about the simplest FPGA program imaginable (one analog input, one analog output). When I run this program using "Development Computer with Real I/O", the FPGA program behaves as expected. The program reads a voltage and outputs a voltage with no problem. I then switch the "Execute On..." location back to the FPGA card, click "Run" and the FPGA VI compiles (successfully) to a bitfile.


I have written the "host" program to run on the PXI chassis, which includes the Open FPGA VI reference to call the aforementioned bitfile and one control and indicator for the output/input. Unfortunately, as soon as I run the Host program, the error -61070 is thrown with the source being "". Can anyone help me with this?


I have attached a zip of my entire project. Thank you.

0 Kudos
Message 18 of 23

Greetings zack.deland


Error -61070 can be caused by a mishap with typedef controls when they are parsed during compilation or a corruption of NI RIO. Since you are not using typedef controls on the front panel of the code that you attached, then it is possible that repairing NI RIO will solve the error. Before you do this however, I compiled the FPGA VI that you sent us and I’m attaching it to my response just in case the problem was not a faulty compilation.


Let us know if any of those steps solved the problem. Have a nice day.


Warm Regards, 

Luis J.
Applications Engineer
National Instruments
Message 19 of 23

Thank you, Luis. I did repair RIO and that fixed it! The small code, as well as my large progam are running perfectly now after recompiling.

0 Kudos
Message 20 of 23