Showing results for 
Search instead for 
Did you mean: 

FPGA Reference Out won't connect to VI Reference In

Go to solution

Hey everybody,

I'm having trouble getting an Open FPGA VI Reference sub-vi to connect with a FPGA_Ready sub-vi.

Everything worked fine until I tried to connect to a new FPGA vi. Now I'm getting an error on the VI Reference Out/In wire, stating: "You have connected two terminals of different types. The type of the source is ( [FPGA Interface]).
The type of the sink is ( [FPGA Interface])."


I've tried several options in the Configure Open FPGA VI Reference dialogue box, including Dynamic Mode and binding the reference to a type definition. It still works if I revert to the previous FPGA vi; the only difference between the two is the addition of two new indicators on the front panel.


Any advice?

0 Kudos
Message 1 of 4

Where did that FPGA subVI come from?  Is that something you or someone else made?  Or is that built into LabVIEW?  I've never seen that one before.

0 Kudos
Message 2 of 4
Accepted by RavensFan

Assuming that FPGA vi is one that you have made; then the problem is that the interface has changed (you added new indicators). Create a control from the output of the Open VI reference function and replace the one on the FPGA SubVI. Or use the Type Definition option (not Dynamic mode) and ensure that the type def is applied to the controls / indicators of the FPGA SubVI.

0 Kudos
Message 3 of 4

All the vi's are from an example project, with slight changes for my application.


I got it to work by creating a control and an indicator from the Open VI Reference output, then copying them into all the subvi's downstream, replacing the existing VI Reference inputs and outputs.

0 Kudos
Message 4 of 4