LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

External Trigger from PCIe-6321 over PCIe-1473R to Basler camera

Highlighted

Hi,


I am  working with a Basler spL8192-70km camera connected to the PCIe-1473R frame grabber with a FPGA.

Now I want to send a trigger signal, for acquiring images generated, from my PCIe-6321 via a RTSI cable to the camera.

Does someone have an idea how to do that, or is there actually a small Labiew example, which I haven't found yet? Thank you very much in advance.


Kind regards

Antonia

0 Kudos
Message 1 of 7
(1,428 Views)
Highlighted

When I use cameras (Usually Point Grey) the input signal needs to be something between 3.3 and 5 V. I am usually triggering them from some other piece of equipment (like a power supply or photodiode). However, there is also an option to send a software trigger, which might work just as well for you. To set this up, I use the following property node, but yours may be different, you have to get the exact names from NI MAX.

 

Software Trigger.PNG

 

Once triggering is set on and source is software, you just use the bottom two strings to continue calling software triggers.

0 Kudos
Message 2 of 7
(1,397 Views)
Highlighted

Hi,


Thank you very much for your answer, I am not sure if I really understood correctly how I can send the trigger signal. Maybe you can show me a small example of how to use this node?

I further also found a example VI called Vision RIO Pulse Generation from the Labview examples. It would be great if I can use it but every time I run it I get the error:

Error -301500 occurred at Vision RIO Unconfigure Pulse.vi. MAQ IO:  The device was not found.

have you ever tried to rout a trigger with this VI to your Frame Grabber?

Thank you very much in advance.


Kind regards,

Antonia

0 Kudos
Message 3 of 7
(1,369 Views)
Highlighted

Hi, Antonia,

 

Have you worked out which option to trigger your camera through 1473R?

 

using 'Vision RIO Unconfigure Pulse.vi'? or

 

PCIe-6321 over PCIe-1473R to Basler camera?

 

Thanks.

 

Roy

0 Kudos
Message 4 of 7
(1,252 Views)
Highlighted

Dear Roy,

 

I am triggering my camera now from an external  over Sync Port at the Frame Grabber. For that I changed the triggering part in the 1-Tap 10 Bit camera with Frame Trigger (FPGA) example. I am routing the trigger signal over the TTL0device line to the CL Control 1 line and it seems to work fine.

Kind regards,

Antonia

0 Kudos
Message 5 of 7
(1,224 Views)
Highlighted

Hey Antonia!

 

Did you ever find out what caused the -301500 Error?

 

Cheers,

Tomi

0 Kudos
Message 6 of 7
(379 Views)
Highlighted

Hi,

Yes I think it was just not possible to use this blocks with that Frame Grabber Card.
I am now doing everything manually.

But if you have some updates or if it is working or you let me know.

Best regards
Antonia

0 Kudos
Message 7 of 7
(374 Views)