LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Export to excel from express VI table is not working

I've connected the USB on the Crio , I'm not able to find the USB drive on the PC. Or is it like that ? And I should just concentrate on the path to save ? 

0 Kudos
Message 51 of 64
(165 Views)

The VI I'm looking at is this one:

current.png

 

If that's what you're talking about, then connecting

  • a Chart to the same wire that is going to the Write Delimited Spreadsheet will give you all of the channels (including the "time" (i) channel, which would just be a straight line on the chart).
  • a Chart to the thick orange wire before the Build Array with the i would give the two channels
  • a Chart to either (one only) of the thin orange wires going into that Build Array would produce a single channel (sounds like what you want).

If you want to use a Graph (not a Chart), then you'll need to store the historic data too (like you're doing with the 2D array going to the "Array" output.

 

You could either

  • use Index Array on the 2D array wire, and then connect that to a graph
  • connect the data source you want (i.e. one of the orange thin wires after the "+" in the current picture) to a Build Array node via a Shift Register to form a thick orange wire (1D array) and then graph that with a Waveform Graph (but not an XY Graph)

That would be more complicated than directly using a Chart though...

Message 52 of 64
(161 Views)

Hi Zaqf,

 

I've connected the USB on the Crio , I'm not able to find the USB drive on the PC.

When you connect that USB thumb drive to the cRIO you will NOT get any new drives on your host PC! You need to check for drives on the cRIO! (Again: The cRIO is a computer of its own!)

 

Try to use the ListFolders function on the cRIO to get all available drives…

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 53 of 64
(159 Views)

This is the VI. I've just used one Daqmx function with two channels . 

0 Kudos
Message 54 of 64
(157 Views)

Delete the Waveform graph and put in a Waveform Chart.

 

(Have you taken any of the tutorials?  Do you understand the difference between a graph and a chart?)

0 Kudos
Message 55 of 64
(138 Views)
Highlighted

I've been using the waveform chart all this while , but I'm not able to get a continuous graph line after 1038 seconds as the chart is being cut/ discontinous. 

Is there a way to get a continuous graph on a waveform. Chart for more than 1038 seconds. 

I tried changing the settings to max limit above 1038 , and it's defaulting back to 1038. 

0 Kudos
Message 56 of 64
(105 Views)

I am puzzled why you are having trouble.  Here is a demo of a 4-channel DAQ device (inner 4 loop) running at 100 Hz (wait time of 10 ms) that I ran for >10,000 samples without a problem.

Chart Demo.pngChart DemoChart Demo FP.png

Bob Schor

Message 57 of 64
(99 Views)

Here's the VI , with which I'm getting a discontinous graph after 1038 seconds . I really don't get the reason why I cant get the graph of the whole time period with the adjusted scale . 

Thank you for your precious time. 

0 Kudos
Message 58 of 64
(87 Views)

Hi Zaqf,

 

I'm getting a discontinous graph after 1038 seconds

How does it look like when it becomes "discontinous"?

Did you check and verify the chart history size? Both charts are set to a history of 1024 elements…

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 59 of 64
(83 Views)

Discontinous as in after stopping the pgm , only a part of the graph is visible , rest of the graph vanishes after stopping.  I think a waveform graph would solve the issue ? How would I get a waveform chart with discrete output ?

Thank you

0 Kudos
Message 60 of 64
(81 Views)