Showing results for 
Search instead for 
Did you mean: 

Executable with serial comm. does not work on new PC. Win NT/98 issue?

The LabVIEW executable QE1800.exe worked fine on a Win NT machine. We moved it to a Win 98 machine and the serial communication does not work any more. Other VIs can still talk to the serial devices. I have serpdrv (tried 2 different versions) in the same folder as QE1800. I also created a QE1800.ini file with a serialDevices=... statement (even though that was not needed on the NT machine).
0 Kudos
Message 1 of 3
Are you using VISA serial calls with an alias setup? Is NI VISA loaded on the new machine? I think we need more information or if you could attach a copy of the VI for us to look at.

0 Kudos
Message 2 of 3
As far as I know, it does not use VISA. I cannot tell for sure, since I do not have the diagrams - all I have is the executable (built with LabVIEW 4.1). The company that provided it is bust. I can tell you however, that NI-VISA 2.6 is installed on the new machine. I do know that serpdrv was needed on the old machine - as I understand VISA calls don't need serpdrv.
I could send you the executable if it helps troubleshooting. The serial communications are with com2 (CVIlaser AB300 filter wheel) and com3 (CVIlaser CM110 monochromator). I have a Blastronix 4-port serial card installed. The ports are showing up properly in windows, and communication with the AB300 and CM110 was established using CVIlaser's own VIs (in LabVIEW 5.1).
One more piece of infor
mation: GPIB communication within QE1800.exe works fine.
0 Kudos
Message 3 of 3