Showing results for 
Search instead for 
Did you mean: 

Executable functioning trouble


Hello everyone,

Thank you for taking time to look at this.

I have created a VI that checks the Weight of a pallet and prints out a label following certain set of conditions. The VI itself runs great however, when I try to create the executable and run the executable, it does not run (Note: Does not even run on the system that has lab-view installed in it).

The executable does not take the input of the weight parameter. I have a VISA set up in the VI and a label printer hooked up.

Please help me solve this problem. This is my first time I am using the application builder.


Thank you

Sudeep Puvvada

0 Kudos
Message 1 of 12

What is the meaning of "does not run". Do you get any error messages? From your next sentence, it almost sounds like it runs, but does not take input. How are things hooked up? 

LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 2 of 12
Do you get any error popup message? I had troubles with an exe that didn't start even if the code itself worked in development mode; in that case a window with a message including "The full development version of Labview is required to fix the errors" used to appear. I got over it by unchecking the "Enable SSE2 optimization" on the bottom of the Advanced tab of the exe building properties. Maybe you could give it a try.
0 Kudos
Message 3 of 12

The application opens up and visually right. The way the VI is set up is that if the weight is above a particular number, it returns a green light or else returns a red light. If the string pulled from the Weighting scale is not a number greater that zero it returns a yellow light. So, now every time I run the application, it returns a yellow light from which I deduced that the Weighting scale is not hooked up right.

The Scale is hooked up through a USB port.

0 Kudos
Message 4 of 12



I do not have any error messages that appeared. Either way I tried what you said,

unchecking the "Enable SSE2 optimization". The application responds the same way.
0 Kudos
Message 5 of 12

You're going to need to get more status info out of the executable while it's running to have any hope of figuring out why it's not working correctly. You can use the LabVIEW development system to debug a compiled executable (unless you disabled debugging when you built it), by opening the "Operate" menu and choosing "Debug Application or Shared Library..."  Step through the execution just like usual, and see where it's doing something it shouldn't.

0 Kudos
Message 6 of 12



I have done what you said. It keeps showing the ERR (-1073807246) which comes up when there are multiple sessions of Labview windows open. I have even checked the box in Tools>>Options>>Enviornment  for "Automatically close VISA sessions". which yielded no results.

Is there anything I am missing?

0 Kudos
Message 7 of 12

I'd try the solutions given here:

In particular, close and exit all of your LabVIEW software, both the built application and the development environment, and even check the Windows task manager to make sure they've terminated properly, then try starting them back up and going straight to debugging your software. That'll make sure that none of your software is inadvertently keeping the COM port open.

Message 8 of 12



Thank that worked.

The application works in the system which has lab-view. However, it does not in my support system which does not have lab-view.

I have installed all the run time engines: Run time 16, 488.2 16, VISA 16 and Serial 15.

These were the once that were recommended when I tried to create a installer.

But the application does not read from the Weight scale. Should be configure the USB port where the Weighing scale is plugged in in some way or something else. Could you please help me with this.


Thank you

Sudeep Puvvada

0 Kudos
Message 9 of 12

Error -1073807246 occurred at an unidentified location
Possible reason(s):
VISA:  (Hex 0xBFFF0072) The resource is valid, but VISA cannot currently access it.


That means some other program has the serial port open and locked it.  Figure out which program is doing that and close the serial port in it.  That could be your development environment, the manufacturer's test software, or possibly you have MAX open and were testing the serial port in there.

Message 10 of 12