LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Executable file does not run another pc

Solved!
Go to solution

Hello everyone,

I built an exe file and installer by build specifications It is running on my pc but not running another one .Installation was completed and I tried to run my app but nothing happened. 

I tried everything what I read on forum and some tutorials. I did exactly all of them but I could not solve the problem. Thanks.

EDIT: the other pc does not have Labview. I wanna run my vi on a pc without Labview  

0 Kudos
Message 1 of 16
(2,621 Views)

Did you install LabVIEW runtime engine on the other pc?

you forgot to mention that.

 

0 Kudos
Message 2 of 16
(2,597 Views)

Thank you for reply,
Yes I did, I installed LVRTE2017_64std on other pc but nothing changed.

0 Kudos
Message 3 of 16
(2,588 Views)

Was the exe created using LabVIEW 2017 64bit? Does it use any DAQ? I have just fixed two issues here, on different machines, where the issue was incompatible versions of DAQmx, but this is only true if DAQ vi's are used in your program

Putnam
Certified LabVIEW Developer

Senior Test Engineer North Shore Technology, Inc.
Currently using LV 2012-LabVIEW 2018, RT8.5


LabVIEW Champion



0 Kudos
Message 4 of 16
(2,581 Views)

@mckosen wrote:

Hello everyone,

I built an exe file and installer by build specifications It is running on my pc but not running another one .Installation was completed and I tried to run my app but nothing happened. 

I tried everything what I read on forum and some tutorials. I did exactly all of them but I could not solve the problem. Thanks.

EDIT: the other pc does not have Labview. I wanna run my vi on a pc without Labview  


In your installer, do you include all necessary runtime environments and drivers as well?

When you nothing happened, do you mean you didn't even get an error?

 

What is the development PC's OS and LabVIEW version?

What is the target PC's OS? Were there any other NI products or drivers installed on the target PC, before you installed your application?

0 Kudos
Message 5 of 16
(2,579 Views)

@mckosen wrote:

 

I tried everything what I read on forum and some tutorials. I did exactly all of them but I could not solve the problem. Thanks.


We have no idea what you tried (and the word "everything" is certainly a lie here!). You don't even describe the error that you get.

 

  • Do you have more details on the "nothing happened"? Did you get any error messages?
  • What is the LabVIEW version you used to create the executable?
  • What is the bitness of the LabVIEW version used to create the executable?
  • Is the PC running any unusual security software?
  • ...

LabVIEW Champion. It all comes together in GCentral GCentral
0 Kudos
Message 6 of 16
(2,571 Views)

there's no DAQ, I created a simple calculator to test executable.

0 Kudos
Message 7 of 16
(2,570 Views)

I have all drivers ,my labview version is professional 2014 , My OS is windows 10 64x and I use runtime engine 14 and 17, I tried both of them when I built installer...I installed runtime engine 17 on other pc.Thank you.

0 Kudos
Message 8 of 16
(2,568 Views)

Try install runtime engine 2014 on the other pc.

 

0 Kudos
Message 9 of 16
(2,557 Views)

first of all, no errors, only there is a circle on my mouse (like running huge program) but not work.

second one ,I use labview 2014 x64.My OS is x64 and other pc's OS is x64 too.

and yes there's a security software,I close it and I have an error now. 

"Unable to locate the labview run-time engine, myAPP requires a version of 2014 (or compatible) labview Run-Tİme engine.................."

 

Im downloading runtime engine ,I thinnk it s gonna run but why couldnt work with avast antivirus ? How can I fix that ? Thank you so much.

0 Kudos
Message 10 of 16
(2,554 Views)