LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Event structure front panel lockout bug?

Highlighted

Hi, 

 

We have LabVIEW 2009. Version 9.0 (32 bit)

 

We have been trying to use an event structure to handle some front panel setup stuff.

 

The problem is that if the code inside one event is being processed and controls relating to another event in the structure are changed the front panel freezes. There are no ticks in the Lock front panel boxes in the edit events panel.

 

More specifically it's the second and subsequent triggers of the second event that cause the lockout.

 

In the attached VI.  Run it.  Click on Switch 1.  Now slide slider Slide, no problem,  slide Slide 2 and see the front panel freeze.

 

Can someone enlighten me?

 

 

0 Kudos
Message 1 of 3
(1,364 Views)
Highlighted

pgaastra wrote: 

Can someone enlighten me?


 

Dataflow prevents servicing the other events until the slow event triggered by switch 1 has completed. You a building a long event queue by moving the sliders while their events cannot react. Bad programming!
 
 
Now, lets' see what the problem is:
 
It seems you tried to unset "lock front panel" for all events, but this is not global to each event frame, but unique for each event.
 
If you edit the event for "slide,slide2" and select "slide 2", you will see that it is still set to lock! Only the event for slide isn't.
 
 
 
 
 

LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 2 of 3
(1,352 Views)
Highlighted

altenbach wrote:
Dataflow prevents servicing the other events until the slow event triggered by switch 1 has completed. You a building a long event queue by moving the sliders while their events cannot react. Bad programming!

Thanks altenbach,

 

I realise it's bad programming - should be producer consumer or something.  I was beginning to see the problem with the long event queue moving the slider caused too.

 


altenbach wrote:
Now, lets' see what the problem is:
It seems you tried to unset "lock front panel" for all events, but this is not global to each event frame, but unique for each event.
If you edit the event for "slide,slide2" and select "slide 2", you will see that it is still set to lock! Only the event for slide isn't.

Thanks for pointing out that too.  I'll go back to the drawing board. 

 

0 Kudos
Message 3 of 3
(1,345 Views)