LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Ethernet modbus over 409999

I have connected my plc with labview by via modbus Ethernet and I have control with holding registers that 400001-40999 but holding registers over that give me 0 all time.

So please tell me if there are some new configuration to overcome this problem.
 

0 Kudos
Message 1 of 6
(1,227 Views)

Hello Nouh,

 

What PLC are you using? How are you controlling it? Do you have a LabVIEW program? Are you using the MODBUS libraries (http://sine.ni.com/nips/cds/view/p/lang/en/nid/201711)? Could you attach your program or a screenshot of it?

 

This article about MODBUS may be helpful to you:

http://zone.ni.com/devzone/cda/tut/p/id/7675

Colden
0 Kudos
Message 2 of 6
(1,195 Views)

Thanks a lot for your attention
but I did as this video do , I used complete project and I controlled my device datacom d500 with holding registers that less than 410000 well but when I tried to reed holding registers above that as 410240 all time give me 0.
http://www.ni.com/swf/demos/us/labview/dscmodbus/

0 Kudos
Message 3 of 6
(1,187 Views)

I'm having trouble finding your device using google. Is it this device? http://www.teknetelectronics.com/Search.asp?p_ID=20264&pDo=DETAIL If not, can you link me to your device?

 

Also, can you send me a screenshot of your project explorer window and your VI? Are you including the 400001-465535 range when adding variables to your project?

Colden
0 Kudos
Message 4 of 6
(1,182 Views)

thank you sir for your response

this is the link of my device and about my prolect i had a snapshot of it

 

http://www.datakom.com.tr/products.php?product_id=185
 

0 Kudos
Message 5 of 6
(1,168 Views)

Hi Nouh,

 

From looking at your code and creating something similar on my side, I'm interested to see how you have it executing. Do you press the run arrow button or the run continuously button? Without a while loop or any other sort of architecture the VI will only execute once very quickly if the run arrow is pressed, which doesn't allow enough time for the Modbus I/O Server to process a value change. Run continuously does allow for a good connection to the I/O server, however the program must be ended with the abort button (which is usually not good practice). Another tool I used to work with this problem was the Modbus Simluator which can be found in the NI Example Finder (in LabVIEW go to Help>>Find Examples, then search for Modbus). Play around with the simulator and try adding registers via "Create Bound Variables..." with the register values you're looking for.

 

Tim W.

Applications Engineering

National Instruments

http://www.ni.com/support 

0 Kudos
Message 6 of 6
(1,151 Views)