Showing results for 
Search instead for 
Did you mean: 

EtherCAT Communication with CompactRIO and 3rd party device.



I'm a beginner about EtherCAT communication and LabVIEW usage...

My 3rd party EtherCAT slave device is YASKAWA SGM7S_R90AA0A servodrive.

I want to connect and use it with cRIO-9068 by EtherCAT communication without any other modules.

The servodrive is using CanOPEN over EtherCAT (CoE) communication.


So, I followed up some manual provided by NI to set up EtherCAT on labview.

This is one of the manuals which I followed up.


I installed EtherCAT master and bring it to my labview project explorer, and I had the slave device below the EtherCAT Master. Until now, it seems to be successful.



(This is my current LabVIEW project explorer window)


But, the problem was started on next steps, so I stopped.

When I right-click on the slave device, I could not find FPGA Target at shortcut menu.

Can I follow this process only if I use NI-9144?


Therefore, this time, I tried to follow the manual using NI Softmotion with AKD EtherCAT drives.

This is the manual.

At this manual, I had to add Softmotion Axis bound EtherCAT Master by right-click the controller item. However, when I tried to bind resourse on my axis, I could not find Ethernet Master.

Is this problem because I did not use AKD EtherCAT Servo Drive?


Now, I don't know how to proceed anymore.

I tried simple example by drag and drop Receive and Transmit element on LabVIEW block diagram window and enter simple numbers on it. But it didn't work.


I have two questions..

1) Is there any other tutorial or examples about setting up and read&write data between CompactRIO and third party EtherCAT device?

2) I tried to solve the problem in two ways. Is there a solution to proceed with that unresolved steps?


Thank you!


0 Kudos
Message 1 of 1