Showing results for 
Search instead for 
Did you mean: 

Errors connecting to RT remote panel

I am running into a problem connecting to a remote panel on my RT target. The vi I am trying to access is included in the startup.rtexe executable, and I can verify its operation with the execution trace tool. However, when I try to open a remote panel connection from the host machine, I get a variety of errors, including 66 (connection closed by peer) and 63 (connection refused by server).
I have configured the vi in question to allow access to all machines (using * wildcard), and also (just in case) included access for the specific IP address of the host. I have tried several different port numbers, including 80, 3363, and 50000, since I seem to find conflicting advice on what ports are to be used for TCP/IP communication. I have even tried enabling web server access, although I don't think I should need to. All to no avail. I'm probably just leaving out one crucial little parameter, but I can't seem to figure it out.
Any suggestions?
0 Kudos
Message 1 of 4

I had a similar experience.

When i did a build and deploy on the a i could see the front panel, but when I ran my application(Host) it did not open the front panel of my RT_applicaiton(RTEXE).

It appears that RTEXE type   do not provide Front Panel as VI type . Even the Web Publish does not update.

You can alway "see" if your application is running via a Network Type Shared Variables linking your Host and RT application.




0 Kudos
Message 2 of 4
Hi TwoCentsHappy,

A LabVIEW realtime application should be programmed as though it doesn't have a front panel. You can create remote front panels for your RT application to see if your application is running. Here is a link  that gives you the instructions on creating remote front panels.

Good luck!
Warm regards,
Karunya R
National Instruments
Applications Engineer
0 Kudos
Message 3 of 4
Correct to my previous reply
You "can" see the Front Panel of the RT RTEXE application on the Host computer.
I had the RTEXE launch at startup via the ni-rt.ini.
Thank you
0 Kudos
Message 4 of 4