LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error while doing wideband spectrum monitoring

Dear Sir, 

wideband spectrum monitoring is being done (50 MHz to 01 GHz) with USRP-2920. Carrier frequency is being sweeped across the whole band. I got an error sometimes after sweeping two times and mostly during first sweep:

 

Error that I encounter is:
The local oscillator did not lock within the allotted time.   

 

I have changed my Rx channel but still i am getting the same error.

Any suggestion or help will be valuable.

 

0 Kudos
Message 1 of 4
(1,188 Views)

Are you able to post your vi as a Snippet or attachment? (Preferably in an older LV version.)

It helps users to better understand what you're asking if they can see the code (and they might be able to catch some errors for you, too).

 

Thank you!

joeorbob

0 Kudos
Message 2 of 4
(1,135 Views)

Dear Sir,

I guess problem is not with the VI. However snippet of my main loop is attached below.

maybe my usrp gets overburdened while scanning but i have increased the wait time inside the loop but the same problem occurs.

 

Regards

0 Kudos
Message 3 of 4
(1,113 Views)

That is not a snippet of your VI.

 

That is a photograph of your monitor.

 

A snippet is something you get from Edit >>  Create VI Snippet from Selection.   Or better yet, the Code Capture Tool you can download from VI Package Manager from JKI.

 

Better yet is to attach your actual VI!

0 Kudos
Message 4 of 4
(1,106 Views)