LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error while calling LabVIEW dll in TestStand

Solved!
Go to solution

I have created a LabVIEW 2020 SP1 dll to call it in TestStand 2020. While loaded this dll, getting the error message "This module was expected to contain a assembly manifest". For debugging purpose, I created a dll for a simple multiplication of two number and the same error occurred while loading it in TestStand.

 

The dll is stored in C:\Project\bin Folder.

 

I also tried creating the dll by checking "Include additional LabVIEW header file" but no help.

 

The dll is working fine when loaded using "Call Library function node" in LabVIEW. but while calling in .net constructor its throwing the same error as in TestStand.

 

Please suggest.

0 Kudos
Message 1 of 3
(361 Views)
Solution
Accepted by topic author RAJESHKUAMR_10

A LabVIEW DLL is NOT a .Net Assembly and can't be loaded as such. Microsoft chose to use the same file ending for those, but they are totally different in every way you can think of, except for the fact that they contain some executable code resources.

 

Teststand has an option to also call standard DLL functions but it's more cumbersome to configure. The alternative is to not create a DLL in LabVIEW but a .Net assembly instead. 

Rolf Kalbermatter
Averna BV
0 Kudos
Message 2 of 3
(320 Views)

That's exactly what I have done Rolf. When calling as C/C++ dll, I am able to load it in TestStand without any error. and the ones created as .NET assembly also loading without error.

 

My DLL is in 32 bit and the TestStand is 64 bit, when calling the dll, its throwing error. Is there any fix for this.

 

I found an article, suggested to use as remote but for that TestStand 32 bit also needs to be installed in the same machine

 

0 Kudos
Message 3 of 3
(261 Views)