LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error when want publish panel at web by using Web publishing tools.

Solved!
Go to solution
2

1


 

As you all can see from the picture.

 

I now want pubsihing my program into web. So I using web publishing tools to create it.

 

But when it want download the panel, it can't run, after that, the web come out " Requested VI is not loaded into memory on the server computer".

 

This sentence, " Requested VI is not loaded into memory on the server computer", what meaning? 

 

Thank you for your helping.  

0 Kudos
Message 1 of 14
(3,074 Views)
Is the VI running on the server computer?
0 Kudos
Message 2 of 14
(3,054 Views)

Hi,Ravens Fan. 

 

Ya. This VI run at server computer.

 

Why this thing can happend? And how to solve it?

 

Thanks for help.  

 

 

0 Kudos
Message 3 of 14
(3,047 Views)

Do you have the LabVIEW Runtime Engine running on the client computer?  I believe this used to be required, although I don't know if it still is.  The error message does seem to indicate that there is a server-side issue, but who knows?

 

Ed DeWitt

0 Kudos
Message 4 of 14
(3,037 Views)

Hi EdDeWitt: 

 

Thanks for your reply.

 

May I ask one question, since I am very new in using LabView, so many things I don't know.

 

Vision Run-Time Engines and  LabVIEW Runtime Engine, this two type of engine is same? 

 

Thank You.

 

 

0 Kudos
Message 5 of 14
(3,034 Views)
I don't know the answer to that one.  I am sure someone more knowledgeable will reply, and hopefully lead you to a solution.
0 Kudos
Message 6 of 14
(3,031 Views)

Nevermind. 

 

Thanks for your helping.  

0 Kudos
Message 7 of 14
(3,022 Views)

Just now, I install LV run time engine already. Also same problem occur. 

 

So, I think not run time engine problem.

 

Maybe is other problem.

 

And then, EdDeWitt, you know what is meaning for this sentence.

" To display VI front panels on the Web, the VIs must be in memory on your computer " 

 

Thank You for helping.  

0 Kudos
Message 8 of 14
(3,009 Views)
Solution
Accepted by awkh38

Have you had a look at the following KB article:

Requested VI is Not Loaded into Memory on the Server Computer

 

A VI is considered to be in memory whenever the program is open on the server machine. The VI does not have to be running. 

 

If the KB article linked above doesn't help, I would want to know what LabVIEW system are you running on your system and how many connections have you setup to the server. The LabVIEW Base and Full Development Systems include a remote front panel license that allows one client connection. The LabVIEW Professional Development System includes a remote front panel license that allows five client connections. Just wondering if that might be causing problems.

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 9 of 14
(3,003 Views)

Hi, Adnan Z......

 

Thanks a lot. 

 

I already saw that article, very helpful. 

 

0 Kudos
Message 10 of 14
(2,997 Views)