Showing results for 
Search instead for 
Did you mean: 

Error when trying to build executable

Go to solution

I'm getting an error when I'm trying to turn my currecnt VI into an exe. I've tried using my setting I wanted, and just using the base settings. I keep getting the same build error, and I'm not sure how to fix it. I'm attaching an snippet of the error message I am getting.

0 Kudos
Message 1 of 11

Did you try manually copying the file from the listed source location to the listed destination location?  It could be a permissions issue of some kind, and trying it manually could give you a more helpful error message.

0 Kudos
Message 2 of 11

I did try that but one weird thing I noticed, is that it always tries to add an extra data file, so if I just use the desktop as the destination it will go to desktop\data, but that folder doesn't exist. If I make a data folder it will go to desktop\data\data, and so on.

0 Kudos
Message 3 of 11

You could try going to the "Destinations" page of the build options and setting the location for the EXE and its support directory to be the same directory (i.e. both your desktop).

0 Kudos
Message 4 of 11

Ok destinations was desktop/data, so that explains that one. I have them both set to just the desktop, copied the dll onto the desktop as well. When I went to build it this time, I got the same error and the dll was deleted from the desktop.

0 Kudos
Message 5 of 11
Accepted by topic author randomguy77
01-08-2018 05:07 AM

I also notice that the path to the DLL starts with a bunch of "..\..\..\..", which means it's stored as a relative path and not a fixed path.  Can you find the VIs that reference it and check the path to see if you can make it fixed instead?  Is this a classic DLL or a .NET DLL?

Message 6 of 11

It is a 3rd party DLL, so I can't say for sure, but I would imagine it is just a classic one.

0 Kudos
Message 7 of 11

If you could open the VI(s) that reference this DLL, you can see whether the calls look like property nodes (.NET) or ugly lumps of data types with a tiny picture of an orange bookshelf on top (classic DLL).  


If it's a classic DLL you can right-click and configure it to point to the DLL location in a more proper manner and see if that helps anything.  You'd have to do it for all instances of the DLL use though.

0 Kudos
Message 8 of 11

I didn't know that. It is a classic DLL then.

0 Kudos
Message 9 of 11


Is there any update with the executable issue?

0 Kudos
Message 10 of 11