Showing results for 
Search instead for 
Did you mean: 

Error out shows an issue with IVI Error, is there something wrong with my labview settings?

Go to solution

Hi all,


image (44).png

I have attached an image of my very simple vi, all i'm trying to do is Initialize the DAQ970, wait 3 seconds and then Close the DAQ970. 

Previously I had code working which involved Initialize, read voltages in a while loop, close, so I know that the setup here with a delay should work. I tried to re-run the "while loop read voltage" vi and it was failing with this error, I tried with this delay and it is failing, I have even tried an Initialize immediately followed by a Close and that is failing in the exact same way too.


The team at Keysight Technology have tried my "while loop read voltage" code on their own personal DAQ970 and have said it is working so they have come back to me suggesting that there may be some issue with my LabVIEW settings that is causing the error converter to fail. Is this possible and is there anything I can change or do to check further why i'm getting this error?



0 Kudos
Message 1 of 3

I don't think the issue is with "error converter", that's just where the LabVIEW error cluster originates from. For example, the code my ask the instrument for its error status, and it returns "-5". But, "-5" only means something to that particular instrument, so you might have a VI that understands "-5" means that the instrument is busy and cannot respond, so then the error converter VI translates that into a LabVIEW error cluster.

Message 2 of 3
Accepted by topic author firasnomaan

I have uncovered what the problem was and unfortunately it was a problem with my laptop and setup. 


I currently have a laptop connected up to the DAQ. I am using Remote Desktop to remotely control that laptop. I have found that if the usb connection from DAQ to laptop gets disconnected and reconnected then sometimes BenchVue and Keysight Connection Expert will work completely fine but LabVIEW remains unhappy about the connection and will throw the I/O error which I was seeing. In order to fix the problem I am currently restarting the laptop and it is instantly okay.

0 Kudos
Message 3 of 3