LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error i/o buffer is not supported

Solved!
Go to solution

Hi

i have a DC electronic load from bk precision having all programming interface.i have chosen rs232 interface and connected through rs232 available on NI CRIO 9045 for programming.they have  given library to initialize device.when i am running that library its throwing some error.please go through error and attached vi snap. how to resolve the error?Is dere any driver?

0 Kudos
Message 1 of 10
(241 Views)

From LabVIEW's help:

Note  Not all serial drivers support user-defined buffer sizes so some implementations of VISA might not be able to perform this operation. If an application requires a specific buffer size for performance reasons and the VISA implementation cannot guarantee that size, use some form of handshaking to prevent overflow conditions.

It seems that cRIO-9045 does not support changing the buffer size. Are you sure you need it? Do you experience overrun problems if you simply drop this setting?

Paolo
-------------------
LV 7.1, 2011, 2017
0 Kudos
Message 2 of 10
(218 Views)

use some form of handshaking to prevent overflow conditions.

how to achieve this one?

. Are you sure you need it?Do you experience overrun problems if you simply drop this setting?

i tried without this configuration(i/o buffer set).but i am not getting expected response from device.

0 Kudos
Message 3 of 10
(207 Views)

@rishijha  ha scritto:

use some form of handshaking to prevent overflow conditions.

how to achieve this one?

Since you are communicating with an instrument, probably you don't have much choice, unless in the instrument's communication settings you could set Hardware handshake or alike.

 

. Are you sure you need it?Do you experience overrun problems if you simply drop this setting?

i tried without this configuration(i/o buffer set).but i am not getting expected response from device.

This does not mean the buffer size is the culprit. How much data do you expect? Do you receive a partial response? If you don't get anything, the reason would certainly be something else.


 

Paolo
-------------------
LV 7.1, 2011, 2017
0 Kudos
Message 4 of 10
(201 Views)

Hi

Since you are communicating with an instrument, probably you don't have much choice, unless in the instrument's communication settings you could set Hardware handshake or alike

ya i have three option in instrument

none,CTS/RTS,XON/XOFF

How much data do you expect?

47 bytes(instrument information)

 

0 Kudos
Message 5 of 10
(191 Views)

You don't need hardware handshake (aka RTS/CTS) for 47 bytes. Should you need get much more bytes, enable CTS/RTS both on the instruments and in VISA.

Disable or drop Set buffer size and try to understand what else is going wrong. Attach your vi for more advices.

Paolo
-------------------
LV 7.1, 2011, 2017
0 Kudos
Message 6 of 10
(177 Views)

You don't need hardware handshake (aka RTS/CTS) for 47 bytes

when my instrument is connected through usb to my pc that time its working fine(for same Vi), i am able to read 47bytes information of instruments.but when instrument(rs 232) port is connected to crio 9045 rs232 port i am getting error am not able to read instrument 47 bytes information.i attached vi and connection diagram.i  set instrument and visa both in RTS/CTS handshake mode.is there any other modification needed in vi??

0 Kudos
Message 7 of 10
(164 Views)
Solution
Accepted by topic author rishijha
05-31-2019 10:46 PM

I can't open your vi because I only have LabVIEW 2017. Would you save it for an earlier version?

Did you check that cRIO's port is working? Are you able to receive the command from a computer?

Also, I guess that the cable you use with the computer is not the same. Did you double check it?

Paolo
-------------------
LV 7.1, 2011, 2017
0 Kudos
Message 8 of 10
(138 Views)
Solution
Accepted by topic author rishijha
05-31-2019 10:46 PM

@rishijha wrote:

You don't need hardware handshake (aka RTS/CTS) for 47 bytes

when my instrument is connected through usb to my pc that time its working fine(for same Vi), i am able to read 47bytes information of instruments.but when instrument(rs 232) port is connected to crio 9045 rs232 port i am getting error am not able to read instrument 47 bytes information.i attached vi and connection diagram.i  set instrument and visa both in RTS/CTS handshake mode.is there any other modification needed in vi??


I would go even further and say that you rarely, if ever need anything other than default flow control.  Enabling hardware handshaking may cause more problems than it solves because some serial cables don't have all the pins connected.

 

It sounds like you are making this needlessly complicated.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 9 of 10
(133 Views)

Would you explain in detail how you solved the problem? It may be useful for other users.

Paolo
-------------------
LV 7.1, 2011, 2017
0 Kudos
Message 10 of 10
(49 Views)