Showing results for 
Search instead for 
Did you mean: 

Error after exe of SFTP connection

On the PC where the Lab View 2023 Q1(32bit) development environment was installed, we converted it to exe only with the attached vi (SFTP example slightly modified), and confirmed that the exe file worked normally on that PC.


However, when I run the exe file on another PC where only Runtime 2023 Q1(32bit) is installed, the attached error appears and it does not work properly.


The error says that OS-dependent characters are used in the path, but I think that this is not the case because I am using Windows 10 Pro.


*The path of the attached file is not listed for security reasons.
However, the password contains @ when used.


Is there something missing when converting to exe, or do I need to install something else?

Download All
0 Kudos
Message 1 of 7

Your attached VIs are in LabVIEW 2023, not 2013.

0 Kudos
Message 2 of 7

Very sorry.

It was a mistake in 2023 Q1.

Thank you for your advice.

It is 2023 Q1 that has a problem.

Runtime is also 2023 Q1.

Corrected original post.


0 Kudos
Message 3 of 7

As a result of examination, I found that it seems to depend on the PC environment rather than converting to exe.

We are currently checking with NI's professional technical support, and will let you know if we find out the cause.

0 Kudos
Message 4 of 7

The stuff about invalid characters is just a wild guess in the error message. Error 1 is a parameter error! This simply means that one of the parameters passed to the function was not valid. Considering that it is the, there is not much that could seem invalid other than the session itself.


Somehow the VI seems to think that the session itself or something inside that session has gotten invalid somehow. Unfortunately a lot of the SFTP functionality is located in a shared library and hence not examinable by us as users.

Rolf Kalbermatter
My Blog
0 Kudos
Message 5 of 7

Dear Rolf

Thank you for your opinion.


Regarding invalid characters, I tried the same input characters on two PCs, and I think that it is not the cause because only one of them came out.


However, even on the PC where the error occurred in Lab View, you can connect via the command prompt or with another SFTP connection software.

Looking at the error, it seems that a timeout error is actually occurring in the


Also,I've tried turning off the firewall, but that didn't fix the problem.


Also, port number: 3704 is used, but it works without problems with other SFTP connection software and PCs that work normally.


I am attaching the detailed error screen and the probe results.






Download All
0 Kudos
Message 6 of 7

I figured out some of the reasons why it didn't work.


It is the point that you have to execute sftp or ssh in the command prompt beforehand and update the known_hosts file in the .ssh folder in C:\Users.

But,this error can be avoided by setting "Trust on first use" in the Lab View property node to True.


However, even after taking the above measures, it seems that timeout errors still occur on Windows 11 Pro PCs, and two of the two PCs have timed out.


The same symptom occurs even if the security software is turned off only with the Windows default.

(Both of the above successful PCs are Windows 10 Pro)


For example, is there a difference when connecting to a Linux server from Lab View with Ubuntu depending on the version of Windows Open SSH?

The version of Open SSH is shown for reference.

[OK] Windows10Pro → OpenSSH_for_Windows_8.1p1 LibreSSL3.0.1

[NG]Widows11Pro→OpenSSH_for_Windows_8.6p1 LibreSSL3.4.3

0 Kudos
Message 7 of 7