Showing results for 
Search instead for 
Did you mean: 

Error SDK Hardware Key Not Found while migrating from Labview to C#, for iHR550+Symphony II




I need to migrate control of iHR550 and Symphony II from Labview to C# to incorporate this functionality into larger project.


The Vis are in attachment.

Firstly I run "iHR550 & Symphony II Toolkits\Monochromator VI API Toolkit.llb\Get Monos From Config"

- to get information about Mono uniqueid and name from Windows registry.

And I run "iHR550 & Symphony II Toolkits\CCD VI API Toolkit.llb\read detector" to get uniqueid and name of CCD from Windows registry.


Then I use "Initialization of Mono &" to initialize mono and CCD. And here the critical places (as it turned out) are VIs "iHR550 & Symphony II Toolkits\Monochromator VI API Toolkit.llb\" and "iHR550 & Symphony II Toolkits\Initialize CCD"


Specifically these are methods "JYMonoLib.IJYMonoReqd.OpenCommunications" and "JYCCDLib.IJYCCDReqd.OpenCommunications".


They are working well in Labview (without compilation, VIs-exe I haven't tried, there is a report about problems here on forum:


But when I write the same in C# these methods don't see Sentinel key. It writes "SDK Hardware Key Not Found. Insert Key to continue".

Error occurs during JYMonoLib.IJYMonoReqd.OpenCommunications() and also during  JYCCDLib.IJYCCDReqd.OpenCommunications().


Here is part of the code (C# project is also in attachment):


private JYMONOLib.Monochromator mono;


mono = new Monochromator();
mono.Uniqueid = Mono_Unique_ID; //Unique ID from Registry, i.e Mono1, Mono2 etc
mono.OpenCommunications(); //error SDK Hardware Key not found
catch(Exception e)
Emulating = true;



Please help.

0 Kudos
Message 1 of 3

Hello dimitriev.g,


I have to admit that I am not familiar with the request "SDK Hardware Key Not Found. Insert Key to continue". This VI's was developed by HORIBA so is a little difficult to know what's missing. Have you contacted HORIBA support to find out what the hardware keys are and how to add them to your C# project?



0 Kudos
Message 2 of 3



Did you ever resolve this issue? I have a similar situation using Horiba iHR320.



0 Kudos
Message 3 of 3