From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error Running Executable on Laptop

I created an executable on labview 8.6 and ran it on a laptop which is connected to an HP 35670A Signal Analyzer via GPID to USB and the executable runs fine(active light flashes), but when i transfer the executable with an installer to another laptop without labview and run the executable while attached to the analyzer the data screen is blank and the active light on my GPID cable does not light/flash. I do not know why the executable would run on one laptop and not the other.

 

Things I have tried:

1. I verified the GPIB Cable works and also tried another GPIB cable which also has the same problem when connected to the deployment laptop.

2. I made sure the address of the GPIB is the same on both machines.

3. I have the drivers for the analyzer and all the other drivers installed on both machines.

4. Created a test program to verify the GPIB and the Analyzer are seeing each other, which verified they are(active light flashed and addresses match).

5. Installed a evaluation version of labview 8.6 on the deployment laptop to see if some necessary files were not transferring.

6. Installed microsoft .net framework on deployment laptop.

 

I am stumped as to why the executable works on the computer with labview but not at all on the computer without labview. Any ideas or suggestions would be greatly appreciated.

0 Kudos
Message 1 of 8
(1,725 Views)
What did you include in the installer besides the exe and the LabVIEW runtime? At a minimum, you would have needed to include NI-488.2 and NI-VISA runtime. MAX and your MAX config would be a good idea.
0 Kudos
Message 2 of 8
(1,711 Views)

I had a ver simular issue with the executables.

the computer without labview still need the run time engine for it to work,

you can add this durring the creation of the executable in the options pages, after then it should work.

0 Kudos
Message 3 of 8
(1,707 Views)

Alright, I packaged the executable with the installer, that contained Visa RTE, RTE, and NI 488.2. Transferred the installer over to the deployment laptop, installed it and ran it and still got no results (laptop still did not initialize). Any more suggestions would be helpful.

0 Kudos
Message 4 of 8
(1,622 Views)

Sounds like you're not paying proper attention to error indications.  Does your code have error checking?  If so, it should stop and report the error, or log it to a text file or something, so that you can see that you got "error 999 when trying to send command" or something.

Otherwise, you're flying blind. 

Steve Bird
Culverson Software - Elegant software that is a pleasure to use.
Culverson.com


Blog for (mostly LabVIEW) programmers: Tips And Tricks

0 Kudos
Message 5 of 8
(1,617 Views)

5. Installed a evaluation version of labview 8.6 on the deployment laptop to see if some necessary files were not transferring.

 
Did you run the source code under the eval version?  If not, try it there.
Maybe that will tell you something. 
Steve Bird
Culverson Software - Elegant software that is a pleasure to use.
Culverson.com


Blog for (mostly LabVIEW) programmers: Tips And Tricks

0 Kudos
Message 6 of 8
(1,615 Views)
The code works perfectly fine when it's on the development laptop, so I am assuming the code is correct. The only problem I'm having is getting the code to run on another computer without labview. I believe my evaluation copy is now expired,since it has been over 30 days.
0 Kudos
Message 7 of 8
(1,612 Views)

The code works perfectly fine when it's on the development laptop, so I am assuming the code is correct. 

 

But you're making assumptions about what auxillary files / drivers / whatnot are needed.

 

All I'm saying is that, since you're already installed the eval version on the laptop, you try and run the source code there, and it might tell you what's missing.

 

Also, what about the error checking question? 

Steve Bird
Culverson Software - Elegant software that is a pleasure to use.
Culverson.com


Blog for (mostly LabVIEW) programmers: Tips And Tricks

0 Kudos
Message 8 of 8
(1,608 Views)