Showing results for 
Search instead for 
Did you mean: 

Error 8 " File permission error ,DMA hard ware Error"

Go to solution

Hello Everyone,

I am student doing masters in Renewable energy systems. I am doing master thesis on Wind tunnel testing which is controlled by DAQ system using LabVIEW. I am trying to operate movement of the X and Y axes by using the program attached below which is downloaded from the companies website of isel as we are using controller C142-4 to operate axes. but when I am operating it "ERROR 8" is showed up saying file permission error. You do not have permission for the file. DMA hardware error detected.

Here are some of the commands that I used for the movement.

@03 to setup No. of axesis(X and Y axes)

@0r1ans @0r2 to set reference point to 0( X and Y axis respectively)

I donot know much about Labview. I have started learning it for my master thesis.

It would be really helpfull if anyone can help me.

Thanking Youin advance


0 Kudos
Message 1 of 3
Accepted by rajeswari1997

Windows does NOT allow programs to create files in the root directory unless they are running with elevated privileges.


Change the directory to a subdirectory of C:\ that you have write permissions to and it works.


BTW: That program is a perfect example of how NOT to program LabVIEW


I suggest you watch this video : VIWeek 2020/Proper way to communicate over serial

=== Engineer Ambiguously ===
0 Kudos
Message 2 of 3

I know this is an ancient post but I just had this same error when I tried to write to a file using an LabVIEW executable (it had worked in the compiled LabVIEW file). My problem turned out to be Norton 360 was preventing the write. There could be other reasons but basically, something is preventing you from getting access. Check permissions and any firewalls. If you use Norton 360, just white-listing your file won't prevent Norton from stopping access. Make sure Norton is set to report any files it blocks, then reboot your computer and run your file again. When Norton says it blocked access, click the "details" link and try to find the place where you "trust this file". Hope this helps.

0 Kudos
Message 3 of 3