Showing results for 
Search instead for 
Did you mean: 

Error -70228 when executing Power on Soft-Motion Axis via EtherCAT


Hey there,


I'm having some trouble when executing the Power Invoke Node on an Bosch IndraDrive CS, which is the hardware for the SoftMotion axis.

My Hardware-setup is a cRIO9064 and on the second network connection the EtherCAT with the IndraDrive and one other sensor. Both devices on the EtherCAT are using the CiA402 profile. The second sensors works fine all the time.

The error message indicates an positioning error, but every limit switch is disabled in the drive and we configured the drive as rotary axis, so there are no hardware limits.

Even the simple Example provided by Bosch is failin, which consists of "activating ScanEngine"(ok) -> "Clear Error"(ok) ->Power (Error -70228).

Combinations I've tested:

      Enable Power (t) and Enable Drive (f) ->Works

      Enable Power (f) and Enable Drive (t) ->Works

      Enable Power (t) and Enable Drive (t) ->Does not work.

I also tried to execute one of the above (working) combinations and add one with both inputs true.. and again error -70228.

For me, it seems, that the drive doesn't execute any power-command at all because we switched off the main power (control power was still on) and got no error indicating missing main power.

Another try was to set the control mode before the power which resulted in a timeout (-70229) from the device.

I'm running LV2017 through all the application.


Did anyone encounter this problem and remembers the solution? I would really appreciate any help regarding this issue.




0 Kudos
Message 1 of 12

If the drive is throwing an error on the transition to Operation Enabled mode (which is the transition from Drive Disabled and Drive Enabled in SoftMotion), then -70229 will always happen since that particular operation timed out. I have a few questions for you about your setup:

- What error is the drive throwing, and are you connected from IndraWorks at the same to troubleshoot there?

- What firmware is the drive running (for example: MPB 20V10)?

- Are you using the SDI Plug-in from VI Package Manager?

- Have you installed any other ESI (.xml) files for the IndraDrive Cs inside LabVIEW?

0 Kudos
Message 2 of 12

Thanks for your questions..

-The drive does not indicate any erros. It displays "Ab" from the time, the ScanEngine is in Active mode until it is back in Configuration. I'm not connected with IndraWorks, because the drive is mission the Engineering-Port.

- FW-Version is MPB-20V13-D5-1.

- I'm using the SDIs from VIPM and also the provided example (which comes along i think).

- I'm just having 1 SDI-Plugin from Bosch. And I also checked the version inside the XML, it's #x24.


Thanks for your reply.



0 Kudos
Message 3 of 12

The only XML file installed in the \IndComm\DD folder for the Bosch IndraDrive EtherCAT slave should be the one installed with the SDI Plug-in, which looks to be "BoschRexroth_IndraDrive_CoE_NI_v2.xml". If you have other XML files loaded, please delete the EtherCAT slave from the LabVIEW project, close LabVIEW, delete the other XML file(s), re-open LabVIEW, and re-add the EtherCAT slave. The reason for this is that the correct PDOs are exposed for use with SDI.


Additionally, that firmware is slightly later than has been tested (20V12 being the latest tested). Start with the XML file check, and I will see if any firmware changes could be causing problems.

0 Kudos
Message 4 of 12

Yay, multiple XML-Files... Smiley Very Happy


I was looking at the installed on in die VI.lib, called Bosch-RexrothIndraDrive-SDIPluginConfig.xml.

There is no XML-File in my project, i've added both (for the other device to) now to the project and will test it tomorrow. But iirc these two files have also been on the target, after I deployed the RT-app.

Additionally, I'll do the XML-Reload tomorrow. The Bosch-one was added automatically by some work with the VIPM, while the other one is manually added from the suppliers page.

Thank you very much, we'll see.

0 Kudos
Message 5 of 12

So the Bosch-RexrothIndraDrive-SDIPluginConfig.xml is a configuration file for binding the EtherCAT slave with a SoftMotion axis and is a component of the plug-in class. The EtherCAT ESI file (also a .xml file) is the one to which I am referring. It can be found at <Program Files>\National Instruments\Shared\IndComECAT\DD.

0 Kudos
Message 6 of 12



thanks for your explanation and sorry for the late reply.

I flashed the whole cRIO and did a reinstall and also imported the two XML-Files for both EtherCAT devices back into LabVIEW and the device.

Sadly, there is no success at the moment.


I tried to read the actual values from the drive while the power-node is executed and for all three combinations (tf->tt; ft->tt; tt) the node reads "f" for Power Enabled and Axis Enabled. The Power-node does not execute and only returns an error for both true inputs.


I had the possibility, to check with another drive, which was working with the official Bosch Example, which confuses me even more. Maybe the drive's parameters are wrong, I'm new to IndraWorks, but we rechecked the parameters and couldn't find anything, also this configuration did work at some point.


a still confused



0 Kudos
Message 7 of 12

If the SDI Plug-in example project works with another IndraDrive, then it is definitely the drive configuration, wiring, etc. I would check with Bosch to see what could be the problem, as my experience with it is also limited. Can you use IndraWorks to run a test move on the axis? 

0 Kudos
Message 8 of 12

With IndraWorks we are able to move the axis.

I thought of a problem with the configuration. i can't configure the drive while in EtherCAT-Mode because i do not have an engineering port and i have to load the default CiA402 Profile and do a reboot. After the reboot of the Drive, i can't configure anything, because the cRIO does not support EoE which the drive supports.

We've also tried to do an offline parameter change in the file and load it to the drive, which fails on the drive.

I'll check with Bosch.




0 Kudos
Message 9 of 12

I am having a similar issue.


Other than calling Rexroth is there a way to get different firmware versions ? I have FWA-INDRV*-MPB-20V17-D5-1-SNC-NN not sure if that will fix it but it is worth a try. 

0 Kudos
Message 10 of 12