LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 7 with Tegam4040 amplifier

Solved!
Go to solution

I recently installed Labview 2014 along with all the other things I need (such as NI-motion, PXI stuff, etc.) and the install went successfully.

I currently have a PXI-1073. which contains a PXI-5152 and the TEGAM4040B instrumentation amplifier, and I have a MID-7602/7604 stepper motor driver that is all connected to the computer to control an experiment where I have to change the angle of an optic and blast it with a laser/collect amplified signals in sequence, etc.

When I reinstalled all the peripherals work fine except that I am now getting the following error whenever I run the sample program that TEGAM gave me to run the amplifier (ie TEGAM4040 - Control [Demo].vi). This .vi definitely worked before I installed Labview 2014. How do I go about troubleshooting this/what is wrong?

 

"Error 7 occurred at Call Library Function Node in Tegam4040 -- Open4040.vi->Tegam4040.lvlib:Tegam4040 - Initialize.vi->Tegam4040 - Control [Demo].vi

 

Possible reason(s):

LabVIEW: File not found. The file might be in a different location or deleted. Use the command prompt or the file explorer to verify that the path is correct.
=========================
NI-488: Nonexistent GPIB interface."

Help me LabVIEWwan Kenobi, you're my only hope... I have attached the TEGAM program .vi for convenience.

0 Kudos
Message 1 of 4
(1,044 Views)

Hi,

 

This error generally occurs if you provide a path that does not exist for dynamic DLL loading. Do you get the same error when loading other DLLs, or just with this DLL particularly?

National Instruments
0 Kudos
Message 2 of 4
(998 Views)
Solution
Accepted by topic author bravedonxiote

I contacted the TEGAM engineer and we were able to get it sorted out with a new updated install package. However, thank you very much for your help. 🙂

0 Kudos
Message 3 of 4
(994 Views)

I am glad you were able to resolve the issue! Thank you for letting us know!

National Instruments
0 Kudos
Message 4 of 4
(981 Views)