LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error 63 when connecting to LAN device

Solved!
Go to solution

I am trying to connect to an Alpha 4160C LED sign that is configured to run through a LAN Ethernet adapter which I have assigned an IP address and set the port to 10001.

I am able to connect and broadcast to the display with device software, but not through LabVIEW. When I run the VI I get the error message 63.

I disabled the firewall and am still unable to connect. 

I am not terribly familiar with this software and any help would be greatly appreciated.

 

Thanks,

Kevin

0 Kudos
Message 1 of 5
(134 Views)

Port may already be in use by the vendor software.  Make sure to close that out first and maybe power cycle your device.  Also, I would recommend adding a "TCP close connection" function to the end of your attached code to make sure that LabVIEW releases that port when the VI is finished running.

0 Kudos
Message 2 of 5
(125 Views)

Thanks for the response, though it's still giving me the error. I checked resource monitor to double check the port is not in use. I also found that when I ran the VI, resource monitor showed labVIEW is trying to connect through remote port of 3580. Is this normal? I appreciate the help,

 

-Kevin

0 Kudos
Message 3 of 5
(121 Views)
Solution
Accepted by topic author karns12
02-13-2019 07:54 AM

I bet that is LabVIEW trying to access the NI Service Locator background process.  Since you have a string wired in to the port number, it's probably telling LabVIEW to look for a named service with a name of "10001", which doesn't exists.  Try replacing that string with a U16 integer datatype.

0 Kudos
Message 4 of 5
(112 Views)

That did it, thanks a bunch!

0 Kudos
Message 5 of 5
(74 Views)