cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error 56 occurred at TCP

Highlighted

Error 56 occurred at TCP

Hello,

We are trying to acquire the Frequency difference data from Symmetricon 5115A instrument using TCP/IP protocol in NI LabVIEW. 

(For your information ,Instrument is directly connected to the host PC so there is no need to have server-client application)

 

Aim of the project is to acquire and record the Frequency difference data every second .

Issue : On giving 1000ms sec delay in the while loop (as shown in the attachment) , we are getting ERROR 56 at TCP WRITE. .

We have tried to clear the error and re-establish  the connection using the state machine , But this process is taking around 2 minutes , which is not needed for the application .

 

Kindly give suggestion for the continues acquisition of the data without error or any break.

 

Thanks in advance

Azhar

0 Kudos
Message 1 of 7
(157 Views)

Re: Error 56 occurred at TCP

Are you sure your instrument ends a message with both a Carriage Return (CR) and a Line Feed (LF)?  You and ending your messages with just a line feed.  So either you are sending the message wrong or you are trying to read it with the wrong termination.  Based on what I am seeing in the code, I would switch to using VISA to talk to your instrument and be sure to have the termination character set to Line Feed (0xA).


There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 2 of 7
(130 Views)

Re: Error 56 occurred at TCP

Hello,

Thank you very much for the quick response.

I am attaching the screenshot of the vi with ("\") code display, It is showing \r\n in the output, Does it mean instrument is sending EOL character? 

Also, I am attaching , the screenshot of NI MAX settings of VISA test panel for your reference.

 

I have tried to replace the Line feed character to EOL character in TCP write command in LabVIEW GUI but still getting the same ERROR 56 .

Also , I tried to concatenate the command with both Linefeed and Carriage Return character in TCP write command , that  also gives the same ERROR 56.

 

Kindly suggest me , if there is any need to modify settings in the NI -MAX or in NI LabVIEW GUI.

Also, The settings in the instrument is not configurable for the termination character.

 

Thanks in Advance!

Azhar 

 

0 Kudos
Message 3 of 7
(101 Views)

Error 56 at TCP write

Hello,

We are getting Error 56 at the TCP write .The instrument Symmetricom 5115A Phase Noise Test set up is directly connected to the host PC.

For your information :

  1. Firewall of the PC is OFF 
  2. The termination character settings of the instrument is not configurable .
  3. Instrument is sending 1000 samples/sec and in our application we want 1 sample/sec, but the phaserate of the instrument is not configurable.
  4. We have tried to clear the error and re-establish the TCP connection , but this process is taking more than 2 minutes , which is not desired in our application.
  5. We have taken maximum timeout and bytes to read from the instrument , but this settings is finding no use in removing this error.

I am attaching the screenshot of VI , Kindly suggest possible solution .

 

Thanks 

Azhar

 

0 Kudos
Message 4 of 7
(75 Views)

Re: Error 56 occurred at TCP

Hello,

  1. I choose Termination character to LF in NI-MAX , and in the VISA test panel , when I give command show freqdiff , it is showing 0A 0D in hexadecimal display(as shown in attached image) ,Also I changed display of LabVIEW GUI to hexadecimal ,  both LF anf CR  termination character is displayed (as shown in attached image . Hence instrument is giving both LF and CR  termination character.
  2. Now , as suggested by you , I tried to write the termination character to LF in the VISA Property node, it is showing the error-1073807331 occured at property node (arg3) (as shown in the attached image)

Kindly help me with the possible solution.

 

Thanks in advance,

Azhar

 

 

 

 

 

 

0 Kudos
Message 5 of 7
(28 Views)

Error -1073807331

Hello,

We are Communicating the instrument "Symmetricom 5115A" using TCP IP protocol . The instrument is connected directly to the Host PC and Firewall of PC is OFF.

 

In NI-MAX , we found that instrument is returning both LF and CR in the incoming message when , we set LF as termination char at NI VISA test panel.

But when we try to write  LF as termination char in the VISA property node , it is showing error -1073807331 at the VISA property node as shown in the attached picture.

Also, while acquiring data of through command  "show freqdiff" , it is showing ERROR 56 at TCP write. , We tried to clear the error and reestablishing the TCP connection , but this process is taking more than 2 minutes which is undesired in our application

 

Kindly suggest possible solutions.

Thanks in advance

Azhar

 

 

0 Kudos
Message 6 of 7
(53 Views)

Re: Error 56 occurred at TCP

Hello,

As suggested by you:

  • In NI-MAX , we found that instrument is returning both LF and CR in the incoming message when , we set LF as termination char at NI VISA test panel.
  • But when we try to write  LF as termination char in the VISA property node , it is showing error -1073807331 at the VISA property node as shown in the attached picture.

Kindly suggest possible solutions.

Thanks in advance

Azhar

 

0 Kudos
Message 7 of 7
(29 Views)