LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 50103 The specified Resource is Reserved

Hi Jay,

That is quite a coincidence!  I was very surprised to see two such similar issues come to me on the same day, so this definitely explains a lot.  I wasn't sure if yours was the same as Linda's since you didn't mention a PC/104 Plus adapter. 

I agree with that we should just go ahead and resolve it over email and then post the solution here once we find it.  Thanks for letting me know!  I will be in touch with Linda.

0 Kudos
Message 11 of 15
(993 Views)

Hi,

I'm using a PCI 4472 and am having the same issue described by Guyver. Someone found the solution to the problem?
I need to resolve this as soon as possible, I am grateful for any help.

Best regards

0 Kudos
Message 12 of 15
(828 Views)

Hello Kirkbardini,

 

1. Has your device/devices worked correctly in the past? If so, what changes took place before you started seeing this error/issue?

2. Specifically, what problems are you are currently seeing

 

As a starting point, please look through the following troubleshooting steps:

 

1. Causes of Error -50103 "The Specified Resources are Reserved" http://digital.ni.com/public.nsf/allkb/485201B647950BF886257537006CEB89?OpenDocument (broken link from the previous posts)

2. Removing MAX Database Corruption: http://digital.ni.com/public.nsf/allkb/2C7480E856987FFF862573AE005AB0D9?OpenDocument

 

Thank you,

 

Regards,

 

Ali M

Applications Engineer

National Instruments

 

 

0 Kudos
Message 13 of 15
(796 Views)

Hi,

I am actually having the exact same error, notably with a PCI-104 slot that is broken out to two PCI slots, one for each 4472 card.

 

In a previous version of my system that was created before I was employed here, the two PCI slots (namely slots 0 and 1) were sharing their interrupts causing issues, so a new breakout board was made. This new breakout board used PCI slots 0 and 2 and allowed everything to work.

 

The system no longer keeps up with what is required, so the old processor was swapped for a new one. Now I am having the same issue as described in this forum. Both cards work fine in slot 0 (so the cards aren't the problem). In slot 1 (which I still have the breakout board for) it seems like it can never stop acquiring. I can acquire continuously with no problem, but it seems to crash when I try to stop it. In slot 2, the card seems to crash before acquisition ever starts. After that request it responds exactly the same as slot 1 after trying to stop it.

 

I have been trying to get it to work in MAX, Labview Signal Express for DAQ, and my own program. I have been getting the same problem with all of them. If I could see the results of those emails or if anyone else has ideas apart from driver reinstall (done more times than I can count) I would greatly appreciate it.

 

Chris

0 Kudos
Message 14 of 15
(664 Views)

Evidently it was people in my department who started this thread, there was just no communication between me and them since they moved to a different site. For those who run into this problem in the future:

 

It seems the issue with the slot 0 and 1 configuration is an interrupt problem. The problem is solved by switching the PCI slot for the second board. This is where my breakout board for slots 0 and 2 came from. Under normal circumstances, this switch would fix the problem. It would be nice if future NI boards didn't have an issue with which slot they were in.

 

The problem I was having with the slot 0 and 2 configuration comes from the new processor board I have. It hasn't been out for very long, and the mistakes made with slot 2 of the PC/104+ slot have just recently been noticed by several people. The issue is being resolved by the makers of the processor board. This issue does not come from NI.

0 Kudos
Message 15 of 15
(592 Views)