From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -2625 Failed to Write File Invoke Node in NI_XML.lvlib:Save.vi

Solved!
Go to solution

I'm getting this error when doing a certain acquisition with a CoolSnap HQ2. The user defines his paramaters then those paramaters are saved to the file so that they can be easly identified later in the database. The error came to us when we did a test with 4 different parameters. We did: Laser X w/ Filter X ; Laser X w/ Filter Y ; Laser Y w/ Filter X ; Laser Y w/ Filter Y.

The first and third one gets saved without errors but the second and fourth get errors. 

 

 

Error -2625 Failed to Write File Invoke Node in NI_XML.lvlib:Save.vi

 

Does anyone have an idea what is going on? Here's the vi i'm talking about.

I forgot to mention that Filter Y's attribute name is 593/LP, could the "/" be the cause?

 

XML.JPG

0 Kudos
Message 1 of 3
(1,618 Views)
Solution
Accepted by topic author GaelC

Found the solution myself. It was indeed the "/" in the name of the filter which caused the problem. I replaced it with a "-" and everything worked 🙂

Message 2 of 3
(1,590 Views)

Hi,

May I know what is that reference you are talking about.I am also getting same error while saving file with the name "C:\GPIB -  XML Changes Version1 without excel\Products\Integrated VARSPD_FURNB_ING\TestData\29 Nov 2018\sssss___29_11_2018_12_28_05.xml"

 

Is this the path that creating this error? Please reply to me asap.

 

Thanks

K Mahesh

0 Kudos
Message 3 of 3
(976 Views)