LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 244: The DataFinder cannot start due to an internal error.

Solved!
Go to solution

I have LabVIEW 2010 and, during Windows start-up, this error message pops up:

 

"The DataFinder cannot start due to an internal error.

 

(244): Please wait till the National Instruments PSP Service is running and try starting the DataFinder again or reboot your computer."

 

I have had this error message pop up for the past year so it is a recurring thing. It started showing up a few months after I had installed the LabVIEW program onto my computer, so I am not sure on what caused this message to consistently pop up. I find that it also causes a delay in the starting up of my computer--my other start-up applications will begin to show only when I close the error window. Please help! Thank you.

0 Kudos
Message 1 of 3
(5,041 Views)
Solution
Accepted by xcontradictorx

Hi xcontradictorx,

 

It sounds like the National Instruments PSP Server Locator might not be started. Could you go to Control Panel >> Administrator Tools >> Services and locate the National Instruments PSP Server Locator? Double-click on it and make sure that the service is started. If it is, stop it and start it again (just by hitting the stop and start buttons). If it is not, start it, then go to the Recovery Tab and choose Restart the Service as the action for First, Second, and Subsequent failures. 

If after change the settings for the PSP service the issue continues I would think that for some reason the PSP service is just being started late for some reason. Could you do a test real quick: disable the DataFinder in msconfig, reboot, then run the DataFinder.exe from C:\Program Files\National Instruments\Shared\DataFinderDesktop\bin. This should place the MyDataFinder app in your system tray (it looks like a yellow gear). 

If this is successful, then we will need to change the order of startup services such that the DataFinder just starts after the PSP service. 

Try the following: 

1) Locate the DataFinder entry from the registry. Located at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run 
2) Delete the DataFinder entry 
3) Add a shortcut of DataFinder.exe to C:\Documents and Settings\All Users\Start Menu\Programs\Startup 
4) Reboot 

This should do all the standard Windows Startup (like starting services, etc.) and then launch the DataFinder. 

One question: do you use the DataFinder at all? Either with DIAdem or the Data Finder toolkit? If not, you could try removing it from the Startup items. Just go to Start >> Run... and type "msconfig". Choose the Startup tab, locate DataFinder, and deselect it. Click apply. This will probably get rid of the error message.

Patrick H | National Instruments | Software Engineer
Message 2 of 3
(5,027 Views)

Hi Patrick,

 

I deselected the DataFinder from my startup items. I believe it should work now and that I will not see the pesky error message anymore. Thank you so much!

0 Kudos
Message 3 of 3
(5,019 Views)